Mad Catz: X & Y Not Working - HELP!


#1

I have just soldered and wired up a mad catz late version common ground controller but X & Y buttons do not do anything during the test on SF IV - all other buttons work perfectly. The soldering looks good but they are not working - any advice would be appreciated.:annoy:


#2

Post them pics so people can assist you.


#3

Looks good? That doesn’t really help… I was recently trying to figure out why my soldering on USB pieces wasn’t working, and everything looked ok; a multimeter told me right away that there was a bridged connection that I didn’t want to have.

If your mad catz controller works in windows, it might be worth plugging it in and seeing if it reports X and Y as constantly ‘on’… that would probably indicate a short between the signal and ground on those two pads.


#4

Did you wire the triggers. If not set the triggers in the game to no function.


#5

are you sure the solder isn’t touching both sides pre-activating the button when the xbox turns on? i had a plotch of solder on one of my buttons and mine did that til i fixed it


#6

I bet this is what it is since it’s easy to do and isn’t very noticeable when it ‘looks good.’ If he did this the buttons will be lit up in the control panel in Windows. Otherwise we need pictures…


#7

Like said, kind of need pictures. Have you tried touching the common ground cable to the copper pad on X or Y and seeing if they activate? Remove your solder and cable then try this. If it works, retry with your soldering.

What smirkis has said sounds very plausible. Get some pics up and im sure somebody could point out the problem straight away.


#8

Mad catz + buttons not working = “working as intended” - Mad Catz
Sorry, couldnt resist.
I dunno, check the wires again. try to short them and see if its going through. usually when you do a bad solder job, the button are stuck on.
Hook it up to your pc so you see there. I think if they are indeed stuck down, you wouldnt know since theyre stuck pressed. the PC game controllers test screen will let you know if theyre stuck “on”