MadCats FS PRO ( Only the stick has stopped working )


#1

I’m trying to figure out what happened with my stick, as I was just switching crown stick to the senwa stick. After I plugged in the USB all the buttons were functional however the joystick did not work at all. After few attempts to fix it, I decided to undo what I did today and connected crown joystick back. However even the crown joystick is not working.

Any similar issues like this ? I just hope I don’t have to replace the PCB because I have no idea how to do that… :frowning:


#2

Take clear pictures of your stick’s innards and show us.
Just you telling us “it doesn’t work” tells us absolutely nothing.


#3

Is the selector set to DP?


#4

what have you tried?

sounds like either you connected to stick harness the wrong way. Harness isnt plugged in. Or you ripped a contact(hard to do)


#5

Ok I took pictures of the inside

INSIDE

[img]http://s27.postimg.org/kbyz5rhj3/Inside.jpg[/img]

Closer up

[img]http://s4.postimg.org/l5tpwpcwp/Inside_2.jpg[/img]

The 2 joystick (crown & senwa)

[img]http://s28.postimg.org/c9untqus9/20141007_093740.jpg[/img]

[img]http://s28.postimg.org/6uqj6ism1/20141007_093754.jpg[/img]


#6

What “mods” did you do to put the Crown in, and put the Sanwa back? On an aside, it’s “Sanwa” with an “A”.

2 things come to mind:

  1. Your LS/DP/RS switch in the Turbo panel is set to “RS” or something
  2. It looks like you’re still using the stock MadCatz 5-pin joystick cable; are you sure you didn’t plug that cable on upside-down when connecting the Sanwa and Crown sticks?

#7

What if he got some Chinese bootleg Joystick with “senwa” written on it?


#8

If I were to bootleg a Sanwa, I’d probably call it “Sanma”. It still sounds very similar, and flipping the “W” to an “M” is a hilarious move. :smiley:


#9

hahaha sorry with spelling, but [

quote=“FreedomGundam;9930207”]What “mods” did you do to put the Crown in, and put the Sanwa back? On an aside, it’s “Sanwa” with an “A”.

2 things come to mind:

  1. Your LS/DP/RS switch in the Turbo panel is set to “RS” or something
  2. It looks like you’re still using the stock MadCatz 5-pin joystick cable; are you sure you didn’t plug that cable on upside-down when connecting the Sanwa and Crown sticks?
    [/quote]

there was no mod for crown it was the one that was made to fit in japanese style joystick. It was working 1 hour prior to the stick not work. Also the 5 pin i plugged in both ways and still no power.

I’m debating if i should order another stick and see if it works or if i have to replace the pcb part or w/e that is … man thats going to be another research…


#10

take a paper clip or wire. plug your stick in and short (create a connection between) the ground and any of the direction. Try it on the stick side, and then try it with just the harness. Post if you need help with this.


#11

I agree with what the above user said. There shouldn’t be a reason why the signals shouldn’t be reading if there is not mods. Also make sure that the joystick is on DP and not LS/RS. Its up near the home button.

This has happened to me before where I panicked and the stick wasn’t in the right position.


#12

yea how would you do this ? is there like webpage where it shows step by step ?


#13

No there is no website or guide that shows this, it is elementary school science.
This is basic electricity theory we are talking about, not rocket science.


#14

^ rude

http://i.imgur.com/flPt38q.jpg

http://i.imgur.com/oRf2xNJ.jpg

the purple circled part is wire/paperclip. One end goes on one side, the other end goes to the other