Madcatz 4716 Common Ground Xbox 360 Pad Dual mod interesting situation


#1

So, i followed the guide on the SRK thread and got my HRAP3 dual modded and working. While playing around with some fighting games i found something that i cant understand too well. The stick works well on the 360 playing all the modern games such as SSF4AE2012, UMVC3, KOF13, etc. But when i play MVC2 the triggers start spazzing out. LT and RT keeps turbo pressing in the game. I then pressed the guide button and switched to SSF4 as it was the disk in my xbox. LT is programmed to HK and HK was not spammed at all In training mode, no inputs were made for LT until i pressed LT. Thinking it was just a coincidence, i went back to MVC2 and it keeps happening. I unplugged the stick and put in my wired 360 pad and it works fine. Also my other 360 madcatz stick works. For some reason i think the padhack is causing problems, but why only in this game?


#2

Listing the model of pcb you used and some pictures of your wiring will help to troubleshoot this.


#3


^ the guide used and followed to solder and wire everything up. Since it was my first dual mod, wiring is very messy. Pictures how close to nothing. I dont think its much of a wiring issue( although im not too sure). But as i stated, the problem only persists in MVC2 game of 360 not any other game.


#4

I would check the yellow pots on the pad. They have these black circular “things” inside of them. They must be set in the neutral position. If they are spun at all, the console will think the trigger is being held down. Different games can behave differently when this happens. I would put in mvc2 and spin the black part until the trigger stops activating. Then hot glue them where they are so they can’t move again. Hope this helps.


#5

I’m sorry, did you try to hack the trigger buttons a well. If so, I guess you had to remove at least one of the yellow pots so my fix wouldn’t apply to you.


#6

yeah i did hack the triggers too with the hex inverter. Dunno if this applies but i got a 2011 version whereas the tutorial is a 2009 version. Was just testing it all day again. UMVC3, and SSF4 works flawlessly. I set LT to HP in MVC2 and it shows that the triggers are being held down. Still doesnt make sense, because if the triggers are always held down, then the buttons wont work in UMVC3 or SSF4. Only in MVC2 it is held down. Any thoughts?


#7

so did you follow the hex inverter picture guide to the letter?
because its wrong

you don’t solder the ground point to the low since its not a true ground
you use a dedicated ground rather than the low pin