MadCatz Fightstick Pro (Xbox 360) not working for the PC!


#1

So I recently got my own fightstick, its a SF x TE Fightstick Pro from Madcatz, got it probably a month or less ago. I have been using my friends fightstick to practice which is a Hori Real Arcade Pro EX (Xbox 360) and that works great on the PC, it was alittle confusing at first but a simple search on google got me to download XCBD which let me use it.

Now I plugged in MY fightstick and it says that the drivers couldn’t be installed. So i google searched for that and found the xbox wired controller drivers and installed them, restarted my computer, and plug it back in. still the same. So I’ve been looking online and have tried almost everything from using all of my 3.0 usb ports to using my HUB and I still get nothing but “Madcatz Fightstick Neo” that cant install drivers or “Unknown Device” I’ve tried unplugging it and switching the mode to LS DP and RS and they all come up with the same two things. This is all bad but the worst part is that I plugged it into my dad’s laptop with the same OS as me >Windows 7 Ulitmate< and it works FINE, it worked automatically on his, all the buttons registered in the device manager and everything. If ANYONE knows anything or whats exactly going on, please please please help me out.

~thank you
ARRR!


#2

Did you try to reinstall your drivers?

As your stick is plugged in.
Go to Device manager
Find your device,
click on it and uninstall drivers
allow the device to have its drivers uninstall
Click on ACTION
Choose and click on scan for hardware changes
Allow Windows to choose drivers from the internet.


#3

I just tried that and it says “Device drivers software was not successfully installed”


#4

I’m posting only because I have the same problem.
I bootcamped Win7 onto my MacBook Pro, only to find that my Round 2 TE, and VS sticks do not install correctly. (My MacBook pro has USB3.0 ports).

However, when I plug it into my desktop (native Win7Pro machine I built myself, USB2.0), they all work fine. There was another thread on getting our x360 sticks to work correctly, but none of the things they suggested worked for me…I eventually gave up (as I also have a Q4RF which does work correctly). If someone does manage to find the solution, I’d be glad to know, otherwise, the only things that seem to work is dual modding…


#5

Do you (both of you) happen to have an nVidia chipset? Apparently, that can cause problems.


#6

I have a Intel CPU and a AMD GPU card :stuck_out_tongue: I don’t have an nVidia chipset, no


#7

Same issue here. Works fine on my windows 8 laptop, will not work on my new retina boot camp Mbp. Won’t work when using parallels either. Pretty damn frustrating


#8

What about your motherboard, though? That’s the part in question. Nvidia makes a motherboard chipset that has a few Intel-compatible models.

In fact, they are really popular with Apple, IIRC.


#9

It should be unlikely on the Mad Catz Pro stick that the UCHI issue is in question.
But to eliminate doubt what is the chipset on your PC and the chipset on the PCs you tested your stick and it works on?


#10

Argh, the Retina MBP has a Geforce GT 650M. Ivy Bridge. (too tired to break it out to run cpu-z right now)

My desktop is a Sandy Bridge i7 2600k, running Intel Chipset.


#11

And I am correct that your desktop is the one with the issues with your stick.

Try this

http://www.microsoft.com/hardware/en-us/d/xbox-360-controller-for-windows


#12

No, the Retina MacBook pro. I actually tried installing the xbox controller drivers and I still have driver issues with the madcatz stick plugged into the rMBP. I THINK someone was theorizing that the issue was with the USB3 ports and the compatibility of TE’s… so I’ve also tried USB2 powered hubs, and no go there, either…


#13

This is very wierd, because the stick should work the way any 360 peripherals work with PC. also nvidia makes a lot of network cards, I have 1 on my motherboard, not sure why this conflicts, i was eyeing one of those sticks myself and now I’m concerned.


#14

I seem to have misquoted things on the 360 stick. The PS3 stick is listed as incompatible, but the 360 isn’t, and makes no mention of nVidia.


#15

Yeah i mean it should theoretically just see it as a 360 controller.


#16

Interesting. Well, I’m keeping tabs on this in case someone figures it out. It doesn’t work for my rMBP, but it does work for my older desktop. It could just be a driver issue (for the mb/chipset, maybe?) <-- all speculation, so don’t take it seriously.


#17

I recently purchased the SFxT fightstick pro for 360 to use on my PC. The stick was recognized by my system as a 360 controller and appeared to work, however i noticed while button checking that something was not working correctly. Button presses and directional movements were inconsistent, sometimes a button press would not register, other times a direction would get repeated until another input was entered. When I plugged the stick into my xbox, it worked perfectly, when I tested it on my brother’s computer, it also appeared to work.

My system motherboard is an Asus M4A89TD Pro USB with the 890FX chipset which uses EHCI for legacy USB support. My Processor is an AMD 8350. Windows 7 64bit

By reading the boards, I found there were issues with the PS3 version of this stick and non intel PC’s. Namely people having their stick recognized, but no functionality due to the fight stick only being able to work with systems that had UHCI complaince . I could not find a problem that was similar to mine regarding button inconsistency but decided to try out using an UHCI compliant USB controller. I was able to salvage an old USB2.0/Firewire combo card from my old P4 box. I researched the NEC chip on the board and saw that it implements UHCI,plugged it in, connected my stick and bam, my stick works perfectly. I have also tested a hori arcade stick on my PC and it works perfectly without the added PCI card, so this problem appears to be with madcatz fightstick pro as far as I am aware, I am not sure if this extends beyond this series of fightstick or all madcatz products. My advice to anyone with a non-intel chipset is to stay away from madcatz unless you are sure your chipset is UHCI compliant. Hori seems to work just fine with EHCI/OHCI USB implementations.


#18

This worked for me.

“First go to http://www.microsoft.com/hardware/en-us/d/xbox-360-controller-for-windows and download and install the driver for your OS.
Then go into the Device Manager, locate the controller, right click it and click Properties > Driver > Update Driver. Choose “Browse my computer for driver software” and then “Let me pick from a list of device drivers on my computer”. Here you select the Microsoft Common XBox Controller (something like that) category and then the newest driver that fits the controller. In my case it was “XBox 360 Controller for Windows Version: 2.1.0.1349”.”

http://steamcommunity.com/app/209120/discussions/0/846959998019081283/


#19

Was just having the issue with the same stick as the TC (Arcade Pro) and this fix worked perfectly. TY BONGO!


#20

I expect some people will be looking for this with the Fight stick Pro deal from Evo shipping out. This solution worked for me with my stick.