MadCatZ PS3 TE FightStick: not working on a Windows 10 mini-PC with Intel motherboard chip?


I’ve read loads of posts about the issue here and in other places where it seems that this model of fightstick had problems with some motherboards but people mentioned that it should work with Intel ones.

I’ve got one mini PC with integrated Intel HD graphic card and Intel mother board but still, the joystick is recognised as ‘PC USB Wired Stick 8838’ by windows but no buttons or stick are then triggered.

Any clue what could be happening this time?
I cannot apply the workaround of buying an external PCI card as this is a mini-PC (similar to a laptop) and it doesn’t have possibility to expand anything unfortunately… :S

Please let me know if you’ve got any idea that I could try or need further info to see what could be happening. I’ve tried installing loads of things, but nothing worked:

  • mad catz drivers for all fightsticks
  • x360ce
  • xpadder
  • vjoy
  • better ds3
  • motioninjoy
  • sf5dinput
  • xoutput
  • RestoreMicrosoftUSBUniversalHostControllerMiniportDriverWindows10

You could replace the controller pcb very easily for about $10. Zero delay encoder with Japanese connections will do the trick.

I have to research further about how to do that (quite late here already), I had a quick look at some videos but they were talking about soldering?

Could you try and find the PCB I’d need if it’s easy to do?

And if I start, would it be possible to use another PCB and make it compatible with Xbox 360 as well as PC?

Here’s one on Focus Attack for reference, but keep in mind that they charge extra for shipping below $40, so you might want to try to find the same thing elsewhere if it’s the only thing you’ll be ordering. Since everything has molex connectors and quick disconnects, installation shouldn’t require soldering.

As for xbox 360 compatibility, I don’t think so, unless you’re willing to spend the money on a brooke universal fighting board, but that costs about much as a used xbox 360 joystick.

A long time ago you might have been able to buy a Mayflash MF002 joystick for about $40 off of Amazon to strip of its P.C.B., but that model has been discontinued, and its successors required you to plug in a controller. I don’t know for sure why they didn’t continue offering direct compatibility, but whatever that reason was may have made other manufacturers reluctant to offer the same thing, which is why I doubt there are other options.

With the PCB encoder you linked as an example, would I lose the switch of the Mad Catz TE fightstick which allows the joystick to work as a Left Stick, D-pad or Right Stick? or would it keep that function in the new board if you know?

There is a mode button you can connect to toggle between left stick and D pad. You would need to either use one of the existing sanwa buttons, add a button (could be as simple as a small momentary switch), or solder to the existing PCB and tap the home button. The first option would be the easiest, and would keep it solder free. You could get by without a select button on PC, just use the keyboard if you have to have it.

And do you know if that Mode button would cover the Right stick as well? Asking because I’m using the stick for a lot of old-school 2D platform games where you need the Right stick for something, like Zooming in our out of a map or redirecting some projectiles, etc…

Quick Load down.

Mad Catz PS3 TE, Not the TE2, TE-S
The original 2 Mad Catz PS3 TE sticks are just not compatible with PC.

Reasons why.

The First two models of the Mad Catz PS3 TE (often called the Round 1 and Round 2 sticks) as well as the original Mad Catz PS3 SE uses a old and obsolete priority Intel USB Protocol called UHCI (Universal Host Controller Interface, trust me when i say it’s not universal ) where you need a ether a UHCI compliant PC mother board or a UHCI complaint PCI card.
(So far I yet to see UHCI on a PCIe Card). Even Intel dropped support for UHCI.

UHCI got replaced by the better and more compatible OHCI or Open Host Controller Interface.
If you got a 64bit CPU in your Desktop odds are UHCI will not work anyways, as there some hardware needed as middleware to make it work, as UHCI only works with 32-bit memory addressing.

I don’t even think there any UHCI compatible drivers for Win 7, so forget win 8 and win 10.
There no amount of drivers or downloads that will fix that mess.

Your only option is a PCB replacement

Thanks, yes, it is a Windows 10 64-bits. I thought I might be doing something wrong as the motherboard was Intel as well and I read that Mad Catz PS3 TE Round 2 should work in those ones, but it isn’t in mine.

I was thinking the PCB replacement but I would need to either keep the Right Stick support or find another PCB which somehow supports it.

I think if that’s too difficult or not possible, I might just end up getting an Xbox 360/PC replacement.

Although I need to research these days if some of those USB converters could make it work, like Cronusmax. I think they advertised their product as allowing PS3 USB controllers to work in a bunch of other systems…

The modern Motherboard being Intel might not even matter as even Intel abandoned UHCI support a long while back. A few VIA chipsets and cards supported it after Intel gave up but thats it.

if you going to get a USB converter, I recommend the Brooks PS3 to Xbox 360 or PS3 to Xbox One adapter as it supports XInput out of the box. And that the Cronus devices has a new issues that I never saw ironed out.

I don’t know why, but it’s quite difficult to find a PS3 to Xbox 360 converter. It seems Brook does loads of combinations but not that one, or not anymore.

That PCB will not give you a right stick input option. The Brook PCB offerings will, but you will need to be able to solder if you want that 3 way switch to work. I think the brook boards let you toggle between inputs via a macro command like the PS360 did, but that will not be a fast change like the 3 way switch.

And the the problem of this stick (TE version) not being recognised by Windows, does it only happen in the PS3 version? or would it happen in an Xbox 360 TE fightstick as well?

Just the PS3 version.


Does the PS3 TE also have issues getting recognized by a Raspberry Pi?

I have a PS3 TE-S that I tried to remap with my Pi 3B, it showed up as a second input device (keyboard connected as well) but then none of the buttons would register on the remap menu. I had a different D/X-input capable stick that mapped fine tho.

The UHCI Issue is with the Mad Catz PS3 TE “Round 1” and Round 2.

The TE-S is a completely different sick than the Round 1 and Round 2 sticks.
Mad Catz at that time switched from using a UHCI PCB to a OHCI PCB.

As for Raspberry Pi, depending on the distros and frontender used and your settings, thats a different ball game entirely


I ended up buying the Xbox 360 version. Windows 10 recognised the buttons and joystick straight away but Steam doesn’t recognised the controller at all, as it’s not appearing in Steam.

Do you know why this could be? or what I could quickly try? If not, I can just create a new post to try and clarify the issue there… :S

Go into Steam’s setting and go to controls and enable Xbox controllers.

In steam everything was enabled, I rebooted but still nothing. Windows is fine though, strange

It was the default driver. Windows added it with the driver for ‘Mad Catz Fightstick’ as displayed in the picture above. I managed to change that driver to the standard Xbox 360 one and it seems working now.

Thanks for the help guys, finally!