Madcatz SE (360) joystick doesnt work


#1

I just bought a modded SE off ebay with all sanwa parts, I plugged it in my pc and installed the drivers but when I test it the joystick doesn’t work. All the buttons are fine is their anyway to trouble shoot this?


#2

i dunno bout that. did you see if it worked on a 360? i know there would be some ways on your pc to figure it out, but IMO i would see if it played on the console. btw were you sure the selector on the top was set to whatever it needed to be, i.e. left stick, right stick, dpad?


#3

If you got windows, go into your control panel and go to game controllers, see if it picks up the stick moving there. Where exactly are you testing the joystick on the pc? MAME/Emulator? quick thing to do would be to open it up and reseat the cables to the joystick to make sure it’s plugged in well/isn’t off a pin or loose.


#4

Make sure the swtich by turbo is set to the digital pad, and not one of the thumbsticks.

I had like 5 hours play, plugged it in again for some mame and had the same issue. I cursed up a storm until I was like 'doh…


#5

I’ve heard that for the 360 controller driver, it should be installed before the device is plugged in. Does it check out in the windows hardware profile?


#6

I have used a wired 360 controller on multiple PCs, and I have never had to pre-install any form of drivers prior to connecting the controller.


#7

Likewise, and my TE worked without any driver installs either.