MadCatz SFxT stick: PC not seeing LT/RT buttons


#1

Crossposting this from the SFxT Pro thread, since that one doesn’t seem especially active…

I recently bought a SFxT Fightstick Pro and it works with absolutely no problems at all on my 360, however when I plug it into my PC, the trigger buttons stop functioning. My PC is “seeing” the buttons, but that’s as far as it gets.

In the above picture I depressed every button, including the start/back buttons. As you can see, every light is on except for buttons 9 and 10, which I’m told are the RT and LT buttons. I’ve also been told a quick fix for first-gen TEs that stopped functioning in a similar fashion was to unplug-plug the stick but that hasn’t helped either.

I’m running the standard Xbox 360 Controller drivers on Win7 64 bit, which have been updated to the most recent version.

The short term fix is just to swap the disconnects between the RT and LB buttons, but ideally I’d like to get the RT and LT buttons fixed: I play on both PC and 360, and I don’t want to be “that guy” at tournaments who has to set up his unique button configuration because he’s a unique snowflake that can’t just settle on a standard config.

Anyone had this problem before, and if so, what did you do to fix it?


#2

I don’t know, but works for my end.
I am too Windows 7 64-bit.

Also, that replug thing is for a different issue with the Triggers.


#3

Hrm. My first thought was that it was just a “360 controller drivers are dumb” thing, but that only affects anything when they’re BOTH being pushed down, but by the sound of it, they won’t register at all, which is probably a different thing.

But for future reference, and on the off-chance I misunderstood, Windows recognizes the analog triggers as two directions on a single axis. So half-pushing RT is like half-pushing the analog stick to the right. Your TE buttons aren’t analog, but they’re still read like that. Thus, pushing both LT and RT would cancel out. It’s trying to simultaneously go left and right on its “trigger” axis, so it just stays in the middle, like you didn’t push them at all.

If that’s useless/You already know, sorry. If it helps, or pushes you in the right direction, awesome. Either way, good luck.


#4

Mad Catz FightSticks do not use the Z-Axis for LT and RT though.
LT and RT are assigned to Button 9 and Button 10.
And both Trigger can be press at same.

I press LT and RT at same time always.
When I am done with a Customer’s Mod to test.


#5

Really? I thought that was strictly a driver thing. My SE Brawlstick is recognized as z-axis, and I assumed it was because (as far as my computer knows) it’s just another 360 pad.


#6

Really?
Man, if I still had some BrawlStick, I would see what the Triggers are on my computer.

But as far as FightStick SE/TE/PRO go, the Triggers are not Z-Axis for me.
I know for sure the SFIV FightPad and WWE BrawlPad are Z-Axis Trigger.

You are saying it is Driver thing?
I use whatever the computer installs upon plugging in.


#7

Pretty sure it is. Then again, my computer’s (read: not the shitty laptop I’m posting from) been dead for a while, so I haven’t used it on a PC in quite some time. I could be mistaken.

Either way, this is the first I’ve heard of any 360 stick sending its inputs differently. Have you tested your RT/LT buttons in anything other than that hardware test window?

I’m holding onto hope that the 9/10 buttons are a lie, and that using the stick in a game will register the inputs as z-axis. But I’m no guru.


#8

It’s definitely not a Z-axis issue. If that were the case, I’d definitely have issues with multiple button presses; I’m not even getting singular presses to register.

The driver thing is a completely different issue. If I plug it into my front ports, it recognises as a “MadCatz Fightstick Neo” and then finds no corresponding drivers… if I plug into the top ports, it identifies as a standard 360 controller. Either way, it’s plug and play (or not play in the case of the former). I have no say in what installs.

edit: I’ve obviously tried it in SF4, and I’ve also tried a few MAME games. None of them recognise RT/LT as being a thing at all.


#9

Well, Button 9 and Button 10 on a normal Xbox 360 Controller correspond to the Analog Sticks.
They are the Left Click and Right Click.
And Triggers on Z-Axis.

But the FightSticks are different.
For super real that when on Xbox 360 Console, the LT and RT do not input Left Click and Right Click.


#10

Have you tried manually installing the 360 pad drivers? At best, you’re stuck with z-axis stupidity, but if it gets single presses to work, that’s progress. And I don’t think you’d need to press both down anyway.


#11

My Win7 SP1 64bit setup reports WWE BrawlStick as Z-Axis triggers. This doesn’t seem to be an issue with SF4 or SSFAE and simultaneous LT and RT presses are okay. However, MAME commandline version treats them as Z-Axis triggers, LT and RT will cancel each other out. I can’t remember if MAMEUI is different behavior from commandline version.


#12

Good to know the BrawlStick has Triggers on Z-Axis.
I don’t have my four anymore to have seen it myself.


#13

Another thing that’s odd is that joy.cpl and MAME commandline reports my Round 1 TE’s LT/RT as button 9/10. The BrawlStick 9/10 stays gray in joy.cpl, probably because it’s detected as a pad and reserved for the analog stick presses as jdm mentioned earlier.