Madcatz SSFIV Arcade FightStick TE: problem with a button


#1

It’s my first post here so I think I should say

Hey everybody!

… or something like that. My apologies if I posted this thread in a wrong section/forum =)

I’ve received Mad Catz SSFIV Arcade FightStick TE for PS3 lately and unfortunately I’ve found a problem. One button (R2) doesn’t work properly. My PS3 thinks that R2 is pressed all the time since the stick is connected to PS3. Also it leads to L2 activates LK+MK instead of LK+MK+HK.

I can’t return the stick so I tried to fix it by myself. I opened the body and reconnected cables (wires) going to buttons. It didn’t help. But it seems that then I touched something occasionaly and R2 and L2 began to work! But… After 20 minutes of playing it stopped working again and I didn’t find a reason why. I haven’t disassembled electronics in the stick yet as I don’t know its structure.

The buttons themself are fine. Do you have any idea what could be wrong?


#2

open the stick and dissconnect the wires for R2… disconnect the wires to triangle and connect the wires from R2 to that button… see if triangle is now constantly pressed… if not I’m thinking its still a pushbutton issue but you gotta rule that out first before you move on…


#3

LOL, now it works again. I didn’t do anything actually, just disconnected wires to R2, turned on PS3 and connected them back. I’ll post when it breaks down.

It’s not a pushbutton problem. I changed wires between R2 and L2 - nothing changed (R2 activated LK+MK, L2 did nothing). PS3 still thought HK button is pressed since the very beginning of a game. Even when I disconnected wires to R2 totally.

I’ve attached images of the stick inside (jic). Say if you need photos of something in the better quality.
http://s018.radikal.ru/i527/1202/ca/9d4b096ca3a1t.jpg
http://s017.radikal.ru/i441/1202/9a/6b3bb54fcbcct.jpg


#4

The stick is still working. I don’t know why but I hope it’ll be ok =)


#5

Short! it´s a short, look at your wires and pcb, there is a short in some place!


#6

Short circuit? Yeah, It’s possible. But how can I check where is it? Wires look fine (they’re too small so I’m not sure though).