MadCatz Sticks on PC & Suspend mode bug


#1

When I suspend my PC and wake it up later on… the Madcatz joysticks will float the buttons and the joystick will go crazy.

The only way to fix it is to unplug it.

Anyone else experience this ?

My 15 year old Namco stick has no such problem.


#2

Hi, I just tested this out with my Brawl Stick but was unable to replicate the problem.

On XP, everything worked as expected.
I also tried it on my other machine in both Vista and Win7. These two OS’ appear to re-initialize the stick before it can be used. I had the Game Controller application open when I put the machine to sleep, and when it woke up no inputs were shown until the list of controllers was cleared and repopulated, and the input display window flashed as though being closed and reopened. However, after this sequence everything tested normal.

What kind of PC are you running? Also, do you have all the Windows Updates? I seem to recall there are several fairly recent patches that deal with USB devices not working right with Sleep mode.


#3

Thanks for the feedback. Im using a PS3 stick and it might work a little differently, theres no re-population of the game controller app, its just there.

Im using Vista 64 on a custom built PC I made myself with all upto date patches.

Its strange my Namco stick doesn’t have any problems. I think the Madcatz are really fussy on what type of USB controller its connected to.


#4

Ah, OK. The PS3 sticks are a whole different controller. :wink:
So disregard what I said - you might have got a lemon, or it might not like your system. My problem is no closer to being solved, but I have confirmed it’s not a power issue. Which just leaves… everything else. Good luck to you.


#5

I found a work around for my problem. Its some kind of USB power issue when the PC comes out of sleep mode the Madcatz PCBs aren’t smart enough to know what low power sleep mode is.

What I have done is used the USB HUB in my monitor (I knew paying more for an expensive monitor would pay off one day ;P) now when it goes to sleep mode, I turn the monitor off also. It completely cuts the current to it.

When I wake up the PC it reinitialises everything and finds the stick again.


#6

It’s good that you know it’s being caused by sleep states. Your solution is probably the best that you’ll find, but if you feel like digging further you can also check if altering your Power Saving settings have any effect.

In your motherboard BIOS, check for anything referring to keeping USB powered in sleep mode, and go through the Wake On (x) Input list. Since your stick isn’t a mouse or a keyboard, turning those options on might not help, but if you’re lucky it might prevent it from entering the low power state it doesn’t like. There’s also a few options in the Control Panel; I believe they only set whether devices can be put into low power modes while Windows is awake, but it doesn’t hurt to try.

For those, go into Power Options and click Change plan settings, then Change advanced power settings. In the list that comes up will be USB selective suspend. The other place is in the Device Manager: Expand the *Universal Serial Bus controllers *branch and double-click each USB Root Hub entry to see if your stick is listed on the Power tab. Once you find it, change to the Power Management tab and see if the option to Allow the computer to turn off this device to save power is enabled.


#7

Thanks for the suggestions I’ll look into windows power options when I have more time, there might be something there that could do the trick. I know there wasn’t an option in the BIOS as I tinkered with that already.