Madcatz TE cord problem?


#1

Ive had my TE for about a year, and for the first ~10 months it worked flawlessly, but a few months ago it started to randomly go undetected by my xbox and i would get the “Please plug in a controller” message from my xbox. It got worse and i noticed it would only really happen if my stick moved, mainly when i tilted the top up or down. I tried to open it up and look if anything was loose, but i didnt really know what to look for so i didnt notice any problems, i eventually duct taped the cord at where it leaves my stick so it couldnt move there, and that worked for a few months but now the duct tape isnt helping and its getting worse to where i cant even play without it going off.

I asked someone about it and they said it was probably the USB cord that needed to be replaced or a frayed cord. I dont know how to replace it at all, and i dont know what cord to use, i assume one of these would work: http://www.lizardlick.com/USB-Cables_c_243.html

but again, i dont know the first thing about this, can anyone point me in the right direction?


#2

To replace the USB cord, just get a new USB cord (preferably around 10 ft. in length to fit in the cord box), snip off the end you don’t need, strip away some of the the insulation with an X-acto knife to reveal four colored wires: red, white, green, and black. Strip away enough to solder to the respective red, white, green, and black wires that are connected to the Mad Catz PCB. Cover with electrical tape.


#3

Yes, any USB cable with an A-type male ending will work.

Also detailed in that video is how you can use a barrier strip to repair your cable, if you can’t or don’t want to solder.


#4

Thanks, seems easier than i expected.