Madcatz TE ps3 + Brooks Universal Fighting Board


#1

Decided to give installing the board a try. I followed the instructions exactly but when plugging into the PC nothing is detected. Looking for any suggestions/input please! :db:


#2

Well you obviously missed something :slight_smile:

Do you have pics of your wiring? Do you have a VCC and GND on all pcbs?

With a ps3 TE pcb, you’d have to wire the USB cable directly to the Brook UFB, but you’ll also need to put a VCC and GND to the main pcb if you are wanting to use the home/turbo.

Did you wire sticks and buttons directly to the UFB or did you Piggy back?

Any information would be handy instead of making a random statement without any substance.


#3

Try PS3/PS4 Modes! Some PC/Windows installations don’t like UFB XInput :slight_smile:


#4

Nothing is detected because autodetection doesn’t work well on PC’s and it goes from PS4 and then settles on Xbox One. And XBOne requires the MS XB One drivers and XB One is buggy even when installed. Use Xbox 360 mode instead. Hold button #3 (punch 3 or hard punch) when plugging in.


#5

vcc and ground all connected
Piggy backed to the ufb
Went from the built in chip to the ufb

Tried all modes. Still nothing. Even if the pc/windows doesnt like it, shouldnt my desktop at least detect something being connected?

Tried it as well.


#6

Um…
When you plug in the UFB, does the blue light come on?
There’s a bright blue light that should come on when the UFB is plugged in.


#7

Blue light is on as well. When I get the chance I’ll upload some photos.


#8

But you hear absolutely NO “USB CONNECT” sound on a PC?
When you plug the UFB in, you should at least hear the USB sound, or some sort of sound, even with nothing attached except the USB cable.

You need to post pics of your wiring, although I don’t know enough to help you with wiring. Someone else will have to.

Also, here’s a little trick:
Even with NOTHING attached to the brook UFB EXCEPT a USB Cable, plugging it into a PC should at least get a controller showing. If you don’t have Xbox One drivers installed, you might get a “Driver missing” error in a unspecified USB Device or a “Controller” with a failed driver install. Then you know the board is working.

Are you using the USB A to B cable, or are you using a soldered on, or JST/Molex USB connector on a presoldered UFB with the VCC/D-/D+/GND pins ?


#9

There was absolutely no usb connection to desktop sound.

Instead of fooling around with the stick and wasting all your time, I just got royalflush to work on the badboy!

Thanks for everything everyone :db: