MadCatz TE R1 (Turbo Panel for Button 3 Stays on?)


#1

Okay pretty much, It won’t turn off I don’t know if it’s the PCB or what I just plugged the stick in a few days back and it turned itself on and has been stuck on I don’t know if there’s any solution even if I unplug the problem button 3 it still stays on. If I unplug the stick and plug it in the light goes off but won’t register 3, because the Game Controller options say button 3 is still activated. I can also seem a dim light staying on inside of the turbo panel


#2

Check and double check all wire harnesses.
Also Unplug the wires to your Number 3 button, and see what happens.


#3

I’ve unplugged my number 3 it still says its on, I’ve checked all the wires they look normal any other ideas to check for?


#4

Try disconnecting the Home/Turbo/DP/LS/RS switch panel (it’s one PCB mounted under the LEDs) from the main PCB all the buttons and stick connects to. If it still reports button 3 as active, then there is something faulty in the main board. Might be the ground or hot connector is loose for button 3 if that’s the case. If button 3 no longer shows as active, then it’s a problem on the turbo panel, which most people can simply play without.


#5

Don’t use turbo to begin with, It just suddenly turned on when I plugged my stick in after a few days of inactivity and wont go off.
So it’s under the main board? Under the panel it shows LED D7 Active others are off and there’s no harness/wire leading to my Turbo Functions on the board.
If there was a way to map my keys in GGPO And just totally ignore it and use another wire I would but you can’t map the keys if a button is being held down


#6

There should be a PCB screwed into the plastic LED/Turbo panel with a wire harness going from it to the main PCB that your joystick has a harness attached to. Simply disconnect the Turbo panel.

You can see what I’m talking about here. The gray ribbon wires going from the main PCB to the PCB in the upper left hand corner. Just disconnect them. If after you still have the same problem, then it’s the main PCB the joystick harness attaches to, and at that point you’d need to get a new PCB.

BTW, PS3 version or Xbox version?


#7

My PCB Looks nothing like that very similar but only has wires directly soldered other then the Harness and the two that run for the buttons terminal, And yes PS3


#8

Could you take a picture please? Up close of the turbo PCB and then of the entire stick open.


#9

Not my pictures but looks like this, And there is no daughter board the ribbon cables go straight to the wire terminal for the buttons.
Minus those orange cables that he has added to his.

http://img844.imageshack.us/img844/6329/img2364.jpg


#10

Oh wow, that’s so weird. Even my first SE was nothing like that. What do the orange wires attach to (derp) and where is the USB cable connecting to? Is there another PCB? (derpy derp) Not that it matters.

The only thing I can recommend is getting a bare paper clip or wire and testing to see if the hot and ground points of button 3 (Should be button X, right?) are good. Basically, unfold the paperclip. Put one end on the point that says GND (lower right corner next to the button solder points) and then putting the other end on the solder point for button X (second solder point down on the lower half of the button solder points) and see if that stops the button from being active. If it does, then one of the two solder points is either cracked or loose and needs resoldered. If you do this, and the button is still active, then your PCB is fucked for the most part as it’s the turbo chip that’s going crazy. I’m leaning towards the latter, since you said LED D7 is lit as active. Once you disconnect the stick, all turbo functions should be wiped clean, but maybe this version of the board has a turbo memory feature. Try testing the ground and hot solder points for button X though.


#11

What you’re testing is if for some reason button X is hot. By bridging the hot point to the GND, it will ground out and deactivate. If the button is no longer active, then the ground point for that button isn’t working, might be a scratch on the PCB trace that is killing it.


#12

Don’t have a soldering iron present till sometime this or next week, Does anyone have a diagram for it? To tell me whats what? Also If you know anyone with there way around a EX2


#13

Did you do the test I suggested? If so, what were the results?


#14

When dealing with something like this its best to try to understand how the button connects to the PCB.

As you already tested the button to see if the problem still exists, I’ll skip that.

Check the underside of the terminal block (the big black strip with the bunch of wires going out underneath it). See if there is some loose wire strand or some way that connection between the Circle (button 3) and the ground points have been be bridged. Should they be bridged/connected, clear the bridge and problem is solved

If the connection is clean at the terminal block, proceed to unplug the harnesses coming from the terminal block to the main PCB as Darksakul has suggested but it seems you haven’t tried. Rather from what you said it seems that you have unplugged the button from the terminal block rather than the main harness that leads from the main pcb to the terminal block. Proceed to test if the unwanted behavior has stopped. If the behavior has stopped, the problem lies within your terminal block. Should the behavior continue, the problem would be related to your main PCB.

Should this be the case, we’ll need full pictures of you own pcb and not nerrage’s PCB.


#15

Heh, had I known there was a terminal strip I’d have suggested something similar. If this is the case, the terminal strip needs checked for button 3/X, the point of contact with the harness, and then where the harness is soldered to the PCB. Need to cover every possibility.


#16

I have tested unplugging it from the terminal same result(Still stays active) will give more details when I can


#17

Ok, so that’s out of the question, then all you have left is to test the solder points by bridging the hot and GND with a wire or paper clip.


#18

Dude, that’s a standard MadCatz PS3 motherboard. You were assuming this was a 360 stick.


#19

It’s been forever since I’ve seen a MadCatz PCB setup, the last time was about 2 years go with a SE. I was thinking about the Start/Select having a separate PCB for the SE, which the TE doesn’t, since it uses normal Sanwa buttons for them. I’ve since moved on to pad hacked Sixaxis, Hori, and PS360+.


#20

Wow, with all of these complaints about the Mad Catz motherboard, I’m starting to NOT want these TEs now, even though the SF X Tekken one is $75 at Gamestop.