MadCatz TE Round 2 for 360 not working on PC or laptop - "Driver not Found"

I’ve looked for a solution for a while but haven’t had much luck.

Neither my PC nor my laptop are recognizing my TE fight sticks as 360 compatible controllers.

My HORI stick works fine, my wired 360 controller works fine, but both the BlazBlue TE R2 fight stick and the SFIV TE R2 fight stick fail to install drivers when I plug them in. I’ve read about chipset issues with MadCatz products for the PS3 controllers but 360 controllers are supposed to be XInput compatible and just plug n play.

I’ve tried every USB port on my systems. 2.0 and 3.0. I’ve also made sure to get the latest and reinstalled all USB controller and INF drivers. I’ve tried specifying the driver manually by taking a look at what .sys files are used by my HORI stick and pointing the MadCatz controllers at it manually but the system still believes they are incompatible.

I’m running Windows 7 64bit (Home premium on the PC and Ultimate on the laptop)

I’ve filled out multiple tickets with MadCatz but they have only responded to one and basically ignored the issue and told me to call microsoft and “ask about their driver.” Thanks guys.

At this point I’m out of ideas. I bought a VIA USB card because I’ve seen that recommended and they’re pretty cheap, but I think that’s only for resolving issues with the PS3 controller and Intel chipsets.

Please advise, any input is much appreciated.

You should have check and posted in the following thread.
Info Thread: Rules, FAQs and Tutorials Inside
Inside you find this link
[MadCatz PS3 TE FightStick on Win7 32/64-bit](MadCatZ PS3 TE FightStick: PC - Xp- vista- win7 32-64bit (read 1st post)

Protip: Always Check the stickies, it is one of our rules here.

Also NEVER email Mad Catz, call them on the phone. If you say “I having trouble” and it involves a Windows PC (regardless who you are calling) they will tell you to talk to Microsoft. Sandisk, Lynksys, Belkin, Apple, Hori, and just about anyone else will just shift the blame to Micosoft.


Is it at least showing up in your Device Manager as an unrecognized device?

If it is…

Unplug your stick

Download Xbox360 controller drivers

Reboot your computer.

Install the controller driver.

Plug your stick in.

Go to Device Manager -> (find your stick probably showing up as an alert icon with unrecognized usb device)
Right click on the unrecognized item and select "Update Driver Software"
Choose "Browse my computer for driver software"
Choose "Let me pick from a list blah blah"
Should list the MS controller driver you installed earlier.

  • If you don’t see the latest MS controller driver then uncheck the “Show compatible hardware” check box and find Microsoft under the manufacturer and on the right find the MS controller driver you installed.

I doubt that Hori and MadCatz drivers are compatible so there’s no point in trying to force them together to kiss.

If you’ve already installed this driver and it isn’t working then you may simply have a faulty Fightstick pcb.

Sorry if this is a bad/repeat thread but I actually looked for a while to find any information on a 360 stick having this issue. All the threads I found were about USB/chipset issues with the PS3 TE R2.

I noticed someone mention:

…which I thought was the case but it seems as though there are still certain MOBOs that the 360 TE R2 doesn’t play nice with.

I’ve tried updating the driver via device manager by pointing the device at the explicit XInput driver file that is used for my other 360 controllers. I’ve also tried downloading the 360 driver/accessories package listed above. No luck. The system doesn’t recognize the device as an XInput compatible input device.

If I plug it into my work PC everything behaves perfectly. It doesn’t work on my home PC or my gaming laptop. Maybe it’s a bad PCB or maybe this chipset just doesn’t work with this hardware.

Yeah I tried all kinds of driver updates before I posted I think it’s just a hardware issue that I can’t resolve. Wasn’t able to find many people having this exact problem with a 360 version of a TE R2

I notice in the TE Differences thread that the 360 TE R2 has an older PCB so maybe that’s the problem at the end of the day.

I honestly had the same problem and I really don’t know how I resolved it myself the other day.

What happened to me was that when I plugged my stick in, “Street Fighter IV FightStick TE” would appear trying to find a driver but “No Driver Found” would appear with the windows driver message.
Typically, when I would plug the stick into ANY different computer running Windows 7 (I run Ultimate, myself) it would find the drivers instantly and install. Normally when this doesn’t happen, you’re supposed to download the regular xbox controller drivers (English x64) and it would let you use the controller.

I had a prior installation of the xbox controller drivers I linked above. I uninstalled that. Restarted my computer. I reinstalled the drivers. I restarted my computer. I plugged my stick in. Finally, it found the drivers and allowed me to use my stick.