MadCatz TE stick button issue


#1

The PPP and KKK buttons stopped working all of a sudden. Everything else works fine though. What should I do to fix the problem?


#2

First, make sure they aren’t working because are disabled in-game. (sounds awfuly obvious, but it doesn’t seem like a coincidence)
If that’s not the case, it could be either the signal or ground cables. You should open the stick to check if everything is properly connected inside.

If you have a Multimeter it could help to test continuity when you press the buttons…


#3

Learn to not rely on them.

This is a good thing, your stick is telling you it’s time to embrace the true 6-button way of life. It’s okay, it’s a hard transition to make. You can start with Sanwa OBSM-30 hole covers to take them out, but what is better is a plexiglass cover without the last two buttons.

It is a trying time, but once you embrace the new way of life, you will thank yourself.

But, if it scares you, try to look around for a loose wire. It is a known problem of the PCB losing the triggers, however, your roundhouse still works, and your PPP is out, which is a bumper. So, that’s good. Maybe look to make sure that a QD isn’t loose.

But maybe someone who knows and relishes in the 6-button lifestyle was messing with the settings.


#4

The buttons are set in-game, they just stopped working in the middle of a match.

The reason I use PPP and KKK is beacause it makes it easier to piano for me so these buttons are important.


#5

Both of those buttons have stopped working?
Easiest way to tell if its the physical buttons is to open up the stick from the top, and test another signal on those buttons, and those signals on another button (for instance, take the quick disconnects from HP and PPP, and swap them, see what results you get. if HP is no longer working its just the button) All you’ll need is a hex wrench, make sure you use the right size (M4? METRIC!) Otherwise you’ll risk stripping the screw on the TE, and then you’ll be SOL.


#6

Do they start working if you unplug, replug? Is it 360? Is it RT/LT?


#7

I’ll assume by your avatar image that you play Chun. What piano methods that you do that end with KKK? I know this doesn’t help solve your problem with the buttons but I’m just curious.

I can piano cl.HK to EX Legs with just the 3 kick buttons and I can slide far st.MP to EX Legs by simply ending my inputs with 2 simultaneous kick inputs instead of KKK. I actually have KKK disabled so I don’t accidentally get EX legs from sliding cr.HP to Legs.


#8

Won’t opening it void the warranty? I tried calling MadCatz but their support is shit.

I piano from short (with my index) all the way to KKK (with my pinky) and then I press the 5th button with whatever strength applies. So if I want roundhouse, I just press the 4 buttons and I’ll use my ring finger for the 5th. It takes time to get used to using your pinky but the buttons on the stick are pretty sensitive so it shouldn’t take too long.

Another reason I use KKK is for the cr.fierce to RH legs. I press fierce+forward then forward+fierce~foward~roundhouse~KKK~roundhouse. It’s just an easier hand placement for me. For the cl.st.roundhouse to EX Legs I piano roundhouse~forward~short and then double tap all three kick buttons at once instead of using the KKK button because for some reason that’s easier for me.

I’m weird.


#9

yeah i just got my madcatz te stick in the mail last week and my RT button dosent work. is this common with these fight sticks when you get them brand new like that? and where do you open the stick at to look inside b/c theres allen screws on the top and phillips head screws on the bottom


#10

Hey guys not trying to stick up for madcatz or anything but I did notice when I took my stick apart to change my buttons I noticed one of the connections/plugs was not connected at all. I dont know if it was a rush job when they were assembling it but it makes me wonder if that wasnt the issue for some of the people that had buttons not working. You will need a hex allen wrench to remove the 6 screws from the top of your TE. I would suggest googling it to see the correct size or look in one of the threads on the forum. Good luck.


#11

Have you contacted Madcatz about it? I got my Round 2 on Saturday and right out the box, moving the stick right while the Triangle and Circle buttons are held down doesn’t work. The game just doesn’t read the input. I sent an email to Madcatz and store.Gameshark.com (where I got it from) and neither of them have replied yet. :frowning:


#12

when last I tried emailing madcatz tech support I got a response 3 weeks later blaming their email system being broken or something. This was reiterated by the person I got in contact on the phone with. My suggestion is to call. I had better luck by phone than I did via email. I too had the RT/LT button issue and after running through the suggestions that some of the above users gave got me an RMA for repair. Kinda glad I got in on one of the deals markman posted, because with return shipping im coming close to having paid retail for the thing


#13

Damn. How long did it take for them to send the stick back to you?


#14

The buttons just started working by themselves again. At least I don’t have to send it in.


#15

hey what is an RMA and where are these posted at that markman post?


#16

Return merchandise authorization - Wikipedia, the free encyclopedia

You usually need to talk to a human send an email to get one.


#17

They have had the stick for a week now with not a peep.

Rufus had it right, and by the markman post I meant I got the rd2 from one of the 100$ shipped deals, the Return authorization I got by calling tech support. I had the best luck reaching someone around 4-5pm PST but thats right before they close for the day.


#18

It’s a fairly common issue with these sticks, contact MadCatz for a repair because if you had it once it will come back. If you feel a little tech savvy ask for a replacement PCB rather than having the whole stick shipped back and forth. Or just go with the grounding of the top and bottom metal plates, it’s worked for quite a lot of us.