Madcatz TE Stick Joystick issues


#1

Hey all, I was recommended by some fellow players to ask around on here about an issue I am currently experiencing with my Madcatz SF4 Tournament Edition Stick Round 2 for PS3. I recently moved home, and as soon as I got all set up, I went to play SSFIV:AE only to find that the up on the joystick didn’t work at all, yet all other functions on the joystick worked perfectly fine.

Now I am not 100% sure what the issue is, I took the top apart to see if the wiring was damaged and it appeared to be fine. I took out the Plug for the Joystick and put it back in just to be safe and alas it still doesn’t respond when I push up on the stick. Just wondered has anyone experienced these issues and if so would I need to invest in a new Joystick part for the fightstick? I have planned to modify my stick in the past so I am thinking prehaps this misfortune might be a good time to actually custom the stick up.

Sorry if this first post of mine isn’t so great, hope it is within the rules and is in the correct area!


#2

Check if the switch is set to “DP” if it isn’t then proceed to open your top panel again and rather than simply looking if the wiring is damaged, try taking off the gate and the Joystick PCB Microswitches. Then look at the microswitches to see if any are damaged or stuck.

You could also check if the JLF wire is hooked up to the main PCB board correctly.


#3

Pictures always help. Especially if it’s not the LS/DP/RS slider.


#4

I have tried a fair few times on LS, DP and RS and pushing upwards on the stick proceeds to do absolutely nothing. I have taken some photos of the parts, though I am waiting to get some more screwdrivers through the post before I proceed to take the Turbo/Home button cover off. Sorry I am still fairly new to parts and taking this apart. I have watched a few videos surrounding the internal parts of the TE but alas I am still getting to grips with it. Any help is greatly appreciated!


#5

Was the wire harness that plugs into the joystick firmly seated there and on the PCB? It could have been loose. It may also be a bad wire in the harness, you can test this with a multimeter if you’re able. It could also be a mad microswitch in the joystick, you should be able to test that with a multimeter as well.

Edit: The microswitch may well be mad, but you only need to worry if it’s a bad microswitch.


#6

The wire harness going into the Joystick was firmly on place on the PCB, it had the original sticky stuff still holding it firmly in place so I don’t think it is that one. It could be a wire but I will have to see if someone I know has a multimeter I could borrow to double check this. There is the possibility it may be the Microswitch for the up direction, but will find out when I get hold of the multimeter. I hope to get it sorted out soon asap, missing playing games with the stick! Thanks for the help so far, shall keep you posted.


#7

After another test today, I think it might be the Microswitch in the Joystick which may be the issue. After taking the stick apart and checking parts, all buttons and directions work, home works, turbo works except for when I push UP on the Joystick. To be safe I think I may replace the Joystick Unit and possibly get a new wire, the PCB connections looked solid and with all the other functions working would it be a good bet to think that the UP Microswitch is the issue? (Just to double check, this is the black box part right? Sorry if I sound idiotic.)


#8

yes, the microswitch is the black box with the little red protrusion. rather than replace the entire joystick, you just need to replace the “PCB Switch Assembly TP-MA.” if all else fails, you can send it in to madcatz, even after the 90 day warranty, and they should fix the problem.

i was considering buying a stick off craigslist that had a few problems. i emailed the madcatz tech team, and they said to send it in regardless of the warranty, and they would fix the problem. unfortunately, by the time i heard back from madcatz, which was the same same day i emailed them, the stick had been sold.