Madcatz TE stick problem, please help


#1

I have had my madcatz TE since about, July of last year. And today it just started to cause a SERIOUS PROBLEM.

The left side of the stick, doesnt move left when it “clicks”, all the other directions work, but to make it go left, i have to mash it hard to the left. Doing so makes, jumping left or charging DB very difficult.

What could the problem be, and is it fixable? if its not fixable do i have to by a whole new stick? or can i possibly just replace the parts inside?


#2

if you have sf4 - go into training mode and view input see if it registers.
have you taken it apart and taken a peek inside?

could be a loose wire, out of center stick (something out of place), or bad pcb
you won’t really know until you take a look inside.

worse case scenario it’s a bad switch or bad ground.


#3

I have not yet looked inside of it, im going to when i am able to borrow something to take the top off. But, when i move the controller i can hear something rattling inside, which doesn’t seem very good to me, i’ll post back here when i find out what the rattling is.


#4

Its either:

  1. The QD partially came off of that microswitch.

  2. The microswitch is busted (case popped open, spring went bad, etc…).

If you are under warranty, send it back.

IF not, either of these should be an easy DIY.


#5

This is going to sound really crazy, but i opened it up and this is exactly what happened.

I opened the case for the first time ever, amazed that the buttons were actually attached to the case itself. I figured, i don’t know what i am doing, the least i could do is try to get the piece i hear moving around out, and take a picture of it and post here to see if it is relevent. So i tried to fish around for the piece, which turned out to be difficult because of the fact that the top was attached, making it impossible to flip it upside down and just shake the shit out of it.

So. I tried to flip it upside down a bit and shook it. something did fall out, but i looked down and saw it was a ziptie and realized that the piece was still in there. After about 20 minutes of trying to reach the piece, i gave up. I decided to turn on HDR and see what the problem looks like from the inside.

And guess what? My controller worked perfect. In fact, not just perfect but actually better than ever. So dumb question time.

Was that zip tie like, stuck somewhere it shouldnt have been or something? or was this just a fluke?


#6

I guess its possible that was the issue…but I’d keep a close eye on it in the next few weeks in case the problem recurs.