Madcatz TE stick won't power on


#1

I bought a MvC2 MadCatz Tournament Edition stick like three weeks ago, and everything was fine. I’ve been careful with it, haven’t been rough, it hasn’t even left my living room.

A few days ago, I tried to turn on my Xbox360 with the stick plugged in, and the system just wouldn’t turn on. When I unplugged the stick, the console powers on fine. Other controllers and my SE stick don’t have these problems in any of the 3 USB ports.

If I turn my console on without the stick plugged in, and then I plug it in, the stick doesn’t turn on. Pressing buttons or the Xbox Guide button does nothing. I’ve tried the lock switch.

What’s going on? I have been able to get it to work a couple times by turning the console on first, and then plugging it in (I have more success with the back USB port), but today I can’t get it to work at all. Does MadCatz have a manufacturers warranty? I bought it from Gamestop, I don’t think they’d refund/exchange it.

Halp.


#2

Well I plugged it into my laptop to see if the issue was my stick or my 360… and my laptop instantly shut off and won’t power on at all.

$100 stick craps out and decides to take a $1000 laptop with it. FFFFUUU


#3

Madcatz has warranty and yes Gamestop would exchange it.


#4

It’s like a death stick