MADCATZ TE2+ Mode Button


#1

Hello,

I apologize if there’s already a thread on this, I tried searching for it and couldn’t find anything related. In fact, I can’t seem to find anything related at all on any other forum either. Anyway, I purchased a TE2+ as part of preparation to play SFV as it came out, and it worked without a hitch for a while, I recently changed the out stick and buttons for custom silent stuff and have had no issues with that whatsoever.

The problem comes in with the “Mode” button, I think that’s what it’s called anyway. I’m talking about the button that has the LS-DP-RS LEDs above it which allow you to toggle the type of movement you’d like the arcade stick to control. When I plugged it into my PC today, it was on RS mode, meaning right stick…and when I press the button, it won’t switch the “mode” that the stick is on. This is incredibly frustrating, as it basically means that I can’t play any fighting games with it at the moment, and I have no idea how I would begin to fix it. Here’s an image of the button I’m talking about:

http://i.imgur.com/oO8K8S0.jpg

If there’s any information you need, please feel free to ask, I tried to be as detailed as possible.


#2

I hate to say this, but how recently did you bought that stick?
I might suggest making a RMA claim and using your warranty.

One thing I can ask, can you reproduce the issue on another PC or console?


#3

The issue happened on my ps3 and pc both. The light just doesn’t change. I’m pretty sure changing parts voids the warranty, right?


#4

I don’t know. It was definitely designed for easy access and Mad Catz provided (or used to) a screw driver.

I want to say swapping the buttons and joystick wouldn’t matter but don’t quote me.
I don’t think it would hurt to ask Mad Catz.


#5

There might just be a connection problem between the black ribbon cables that connect the main board to the panel with the Mode button. I would start by disconnecting and reconnecting those, and if that didn’t work, maybe testing the connections.


#6

I assume you’re talking about these black ribbons. If so I’ve disconnect and reconnected them several times, no good.

http://imgur.com/xR9qUEz.jpg


#7

Ow,
Looks like an RMA is in order :frowning:
Is that “Mode” button a single button press where you press it 3 times and it changes state?
(Sort of how the Qanba Q4raf switches from DP to LS, except it always defaults to DP).

Looks like someone did the soldering /wiring job on that PCB on a Friday or something.
On older madcatz controllers, the lever mode switch was done by a 3 pole switch that would just bridge circuits, and lock/unlock was a two way switch, like how your PS3/PS4 two way switch works.

Hope the replacement goes smoothly. Madcatz quality has gone down since their main guy left the company :frowning:


#8

Maybe it’s dead old, but I provide some solutions to this:

For those who have their Mad Catz TE2+ locked at RS, I have three solutions that are following:

  1. In PS4, do the followings:

a) Connect it to PS4, then press the switch button ONCE to bring it to “LS” mode.
b) Log out of user, and then log in again BEFORE you press the switch button again to bring it to “DP” mode.

In PC, you need to map the right stick into movement buttons. You cannot do the log-in procedure like the PS4 has.

  1. If you have soldening skills as an electronic, or you have an electronician friend, you gotta desolde ALL the Diodes, EXCEPT of the D1, D2, D3, D4, and D5, for those are the LED lights.

  2. Last of all, find EZ mod pcb and buy it for $120+ to replace the defective pcb.

BTW, @IronTrigger, can you tell me how did you disasseble that part to reveal their end right on the Lock/Switch buttons? I wanna try reconnecting these wires.