Madcatz TE2+ not working in any PS4 games (except home menu)


#1

HI all,
I’m new to this forum, but not new to gaming. So as the title says, I just received my BNIB Madcatz TE2+ ps3/ps4 fightstick (the one with Ryu artwork) from Amazon.

The stick only works in PS home menu. I can navigate thru the menu with absolutely no issue. PS home button works and everything. But as soon as I load up SFV, nothing works, except the home button and the share button.

I tried the legacy controller function and it doesn’t even recognize the fightstick. However, when i plugged in my PS3 Hori stick and use the legacy controller function, that works! So I can play with my Hori stick…Had I knew about this function, I would not have purchased the Madcatz.

I’m totally bummed out… this fightstick seems like a piece of art but it just doesn’t work like it’s supposed to. Anyone has had this issue and fixed it? Any ritual that I need to perform to make this work? I want to see if there is any way to make this Madcatz work before calling up Amazon for a refund.

Appreciate your help!


#2

there may be a button stuck (always ON) so can you test in under a windows PC and run joy.cpl? If that’s the case removing a few electronic parts from the PCB can solve your problem

post pics if possible.

Thanks


#3

Thanks Torta, i flipped on the joystick and all the round buttons seem to be normal when pressed, no signs of being stuck…

i will check the top buttons (lock/unlock, ps3/ps4, etc) tonight… see if any buttons appears stuck or sth… will post some pics later as well…


#4

It’s a stuck button problem imo

You should search for the fix in the forum (faulty diodes)