Madcatz xbox360 LT/RT help


#1

So I am having a little bit of trouble with this pad. I removed the triggers and used a 4.7K ohm resistor so I can use the triggers. The problem is they will only activate when I release the button. For instance, I press down on the button, nothing happens. When I release the button, the LT/RT will activate. Any ideas on what is going on here?

Also, I’ve done these in the past with no issues but this pcb looks a little bit different from the ones in from the past. It’s still common ground since all the other button work as they should. Just trouble with the triggers. Thanks in advance!

Pics…

http://picasaweb.google.com/wliu0912/PrehackedPads#5275066499737886146

http://picasaweb.google.com/wliu0912/PrehackedPads#5275066502389173362


#2

I’m facing the same problem. Anyone know how to resolve this?


#3

Sounds like the new rev doesn’t have the triggers active low. Does anyone have one unhacked, with the trigger assembly still on? I’ll bet the voltage on the middle line is low when not pulled, and high when pulled, by the sound of it.

There was someone who put up a quicky schematic in the padhacking thread to use triggers that way with a transistor on a common ground setup. Let me see if I can find it.

Damn. I can’t seem to find it. Let me take a peek over my class notes and see if I can figure something out. I know it can be done with an inverter chip, but I’d like to see it done with smaller components.


#4

Alright, talked with my circuits prof and found it out. I bet the other guy that posted the transistor method I’m thinking about did the exact same thing.

Each trigger will need two pull up resistors (5k-10k ohm, doesn’t really matter so use whatcha got) and an NPN transistor. Lots of options for these; they’re even one of the few components Radio Shack still carries.

both resistors have one leg connected to vcc (+5v, power, etc). R1 ( the other leg of resistor 1) goes to the middle pot pin and the C (collector) pin of the transistor. R2 (the other leg of the second resistor) goes to the middle B (base) pin of the transistor and the signal line of the button. E (emitter) pin of the transistor goes to ground.


#5

Hey thanks for the info Toodles. I tried to quickly sketch up what I think you are saying. Now I’ve never taken an electronic class in my life so this sketch is probably all kinds of wrong but I hope you can make sense of it.

Also, thanks for the tip about it being in the pad hacking thread, I looked through it and the only thing I found was in here.

http://forums.xbox-scene.com/index.php?showtopic=618909&st=30

Only thing is that they are talking about the new CG official MS controller and using a PNP transistor. Not sure if that’s what you were thinking about.


#6

Huh, the one on the xbox-scene forums has three resistors (check the problem on post #47, and RDC’s solution on post #50)

Picture needs one tweak; see the junction of the +5v, wiper, and resistor? erase the resistor, put a wire in its place. Erase the wire connecting the junctions to the +5, and put R1 there. Otherwise, looks good. (And, normal caveat; this is untested, may not work, if it breaks you keep both pieces.)


#7

Okay cool, thanks for the help again. Will try it out sometime this week and post the results in case anyone else is running into this issue.


#8

i just ran into one of these today and will be getting the transistors tomorrow.

kind of confused on which ones i need because in the pic on xboxscene it says pnp but the ones you say to use toodles are npn. does it matter which kind?


#9

Nah, you should be able to use either, but connect them up like I described if you get NPN and like described on xbox-scene if you get PNP.


#10

The problem I’m facing now with triggers is that it’s always pressed and it’s released when I press the button.

Will Toodles method solve this? or am I missing something?


#11

Toodles, you are a genius! Tried doing what you suggested and it worked like a charm. Excuse the sloppy soldering but here’s a pic…

Also, I think you can tell which ones has the harder to hack triggers by the packaging. The one on the left in this photo is the harder trigger hack one. The one on the right is the easier trigger hack one. Hope this helps out other folks.

Thanks again Toodles!


#12

yeah, sorry for posting late but i went with the toodles method too and it worked.

thanks man!

also, wanted to mention the gamestop rebranded madcatz pads also have these new pcb’s in them and the packaging looks exactly the same as the old ones i think.


#13

You’re F’ing crazy if that is your idea of sloppy soldering. :slight_smile: Glad to hear it worked guys.


#14

In case you or anyone else would prefer, another way would be to use an inverter chip like a 74XX04 or 74XX14. (XX indicates the family of chip. I usually go with HC’s, AC’s, HCT’s or ACT’s unless there is a good reason to use otherwise.) Here’s a digikey listing for an HCT14:
http://search.digikey.com/scripts/DkSearch/dksus.dll?Detail?name=296-2093-5-ND

Connect the high voltage trigger pad to pin 14. Connect ground to pin 7 definitely, and it’d be best if you also connect ground to pins 5, 9, 11, and 13. On pin 1, connect your left button signal wire, and also connect pin 1 to power through a pull up resistor (5k-10kohm). On pin 3, connect your right button signal wire, and also connect pin 3 to power through a pull up resistor (5k-10kohm). Connect the left wiper line on the pcb to pin 2, and the right wiper line on the pcb to pin 4.

Using transistors requires a total of four resistors and two transistors per pad; this way requires two resistors and one chip. use which ever way is easiest for you. The unused pins are unused outputs; feel free to clip those off close to the chip.


#15

Hey Toodles, will this transistor work?
http://search.digikey.com/scripts/DkSearch/dksus.dll?Detail&name=UNR421300ACT-ND

Michael


#16

cool, I didn’t know such things existed. That one in particular won’t, or at least you would still require at least one resister per. There’s nothing pulling the collector pin to high voltage, so it’d be floating or low, when we need it high or low. I’ll see if I can find anything similar that’ll do what you’re thinking though.

Nah, neither of the NPN or PNP prebiased transistors I can find will do what we want without an additional pull up. If you’re trying to reduce part count or cost, go with a digital inverter chip (7404 or 7414)


#17

I have a few 74HTC04 chips on hand and I can’t seem to get things working right now. I have the chip wired as your instructions above. One thing I discovered is that the pots are reverse of each other on the pad. Looking at the bottom side of the pad with the pots pointing to you here are the pin-outs from left to right, High, Wiper, Low : Low, Wiper, High. That probably means nothing. I also measured the resistance between the high and low side of the pots, one measured 9.3k and the other was 8.9k. I am using 6.8k resistors.

I already have this pad striped down but I still have the pots on hand and can reinstall them if needed.

What is happening is when I touch the ground wire to the wiper nothing. When I touch the ground to the high side it reboots the pad. I may have something wired wrong but I can’t see it.

Hit me up on IM if you can.

Michael


#18

Don’t ever do that. That’s the very definition of a short circuit.
EDIT:Forget what I originally had here; was still asleep.


#19

Thanks,

After installing the resistors on the pad both triggers register as pressed. I press the button on each trigger it turns off then back on when the button is released. I took off the chip for now so I can step through the install and troubleshoot.

Michael


#20

Now I have the chip installed. I looked over my soldering job on the perfboard, it was a mess. I cleaned it up and re-soldered the ciriut making sure everything was clean and correct. This time it works as it should.

However the joystick (not the d-pad) shows movement each time I press a trigger button. When a button is not pressed the joystick is dead center. When a button is pressed it moves halfway to the upper right corner. I have the controller connected to my PC and looking at the Windows properties window. This only happens for the triggers, the digital buttons don’t have any affect on the joystick.

Michael