Mame++, no audio if joystick plugged in?


#1

I modded my old dreamcast agetec with a 360 pad in it. works perfectly fine in my 360. works perfectly fine in windows game controllers diagnostics.
for whatever reason no roms will load with audio if the sticks plugged in. Unplugged, they work fine. I plug it in mid game, mame wont detect it and will undo all mappings to the stick.
if i start with it, no audio. unplugged, still no audio.
any idea wtf is going on?
I tried diff ports, same thing.

Actually lets take it a b it further. 2dfighter doesnt have audio, and seems firefox lost all audio includin youtube until I restarted firefox… wtf?


#2

Is the audio missing completely from your computer when you plug in the joystick or is the audio just not being output specifically by the programs themselves?


#3

Yea I tried some more combinations.
Apparently when the sticks plugged in I lose ALL audio everywhere, unless it was already loaded.
I can start an mp3, load up a youtube vid, etc. plug in the joystick, they keep going. if I hit stop, then play on the mp3, then no sound. refresh the youtube link, no sounds.
Windows makes the hardware detected, disconnected sounds, however even in sound control panel, nothing makes any audio while its plugged in.
its some standard onboard audio but ive never had any problems before. im trying 3 different usb interfaces and all do the same thing…
very weird.
its a joytech se pad, windows detects it as
controller (v31.22)
im gonna guess a driver issue somehow. how could i use a diff driver since this was a default detected one?

Ok, solved that mystery. I guess because I have a headphone extension in it, for whatever reason it came up in device manager as a usb audio device so it decided to defer audio to that I assume.
Disabled it and alls fine…