MAS stick not working with Total Control Plus. Baby Jeebus cries. Details inside


#1

I posted about this in the converter thread, but I figured I’d make a thread to get more eyes on the problem I am having (and avoid cluttering up the converter thread).

I recently purchased a MAS 8 button stick from Arcadeshock. I received my Total Control Plus converter in the mail yesterday. Excited, I hook it up (even following the instructions on the back of the box perfectly). I turn on my Dreamcast with Capcom vs SNK. I was kinda weirded out at first because instead of playing the dreamcast graphic upon bootup the logo just appeared. So I figure no big deal. I’ve got my VMU in, converter on, and I’m ready to play. Well, the stick didn’t work. None of the buttons registered. I noticed that it appeared the stick was stuck in a down position because it kept cycling down through the record menus. I try the stick on all three settings with the exact same results. I pull the VMU out and that didn’t help. I tried another Dreamcast. Every time I had the same issue.

Well, I’m thinking the converter is fubared. Wrong. I hooked in an official Dual Shock 2 controller and found that the converter actually worked flawlessly. Played a few rounds using it and was satisfied that the converter worked as it should. As an experiment I connected a controller extension cord to the MAS stick. Nothing changed.

Now this stick works perfectly on PS2. I think I have tested everything I possibly can here. I think i’ve pretty much ruled out everything but the stick itself. I am including a few photos of the wiring below:

I would be very grateful if one of you guys can help with my situation here. One of the main reasons I purchased this stick was for my collection of DC fare, and I’m very bummed that I’m having this issue. Especially since it does not appear to be a widely reported problem.


#2

Hmm, besides missing an analog button, the stick’s innards looks the same as my friend’s PS2 MAS stick. They must’ve changed something in their chip. Can’t help you much here =\


#3

im digging the hair on that tape


#4

Thank you Gasp for my ‘once a day’ laugh.


#5

damn thats some sick soldering…


#6

Are you able to check if the MAS works on a PS1? I had a 3rd party ps2 pcb that didn’t work on a ps1, iirc the total control plus was intended as a PS1 controller adapter.


#7

I think I actually remember reading that Mas sticks don’t work with any convertors outside of ones provided by Mas themselves. They used to sell Xbox convertors a few years back and their convertors didn’t work with anything but their sticks in the reverse. They don’t hack PCBS, they create their own.

Short of replacing the MAS PCB with a hacked one, you’re best bet would be to call mas and ask them if they sell a DC convertor.


#8

I think this is a more recent problem and most likely has something to do with MAS changing something in the PCBs they use.


#9

I emailed Arcadeshock about it and got this reply:

Hello Kendall,

Glad the stick worked out for you. We aren’t sure why we still sell the concave buttons, but we guess it would be for the gamers that haven’t experienced them at all.

As for the converter situation, MAS does change it’s custom PS board over time. They do not guarantee it work with any other converter, unless they sell it themselves. The only converter that they guarantee will work with their stick is the one for the Xbox, which we used to sell, but sold out a while back. My only recommendation in this is to find someone who recently bought a MAS stick within the last 6 months with the same converter. Chances are, the ones that claim to work might’ve bought the MAS stick over a year ago. The companies that make these converters go out of business and stop making them, so MAS, when and if they use the converters, have to reprogram their custom board accordingly to work with their sticks. It’s unfortunate that this has to happen, but this is just the nature of a changing business.


Unfortunate if this is true. Kinda changes the converter game for MAS sticks a little.