Mayflash stick issues


#1

So i got a mayflash arcade stick for cheap and decided it would be a nice little modding project. Took out the stock stick and buttons and replaced them with a Ls - 32 and some white sanwa buttons i had in my toolbox. It works perfectly fine for ps3 (other than not having a home button…) and pc.

The only issue i’m having is when i plug it into my ps2 i have no directional control at all. All the buttons work fine but i can’t move around any menus or move my character around etc. Note that this only happens on the ps1/2. If i plug it into an inpin or pelican converter for ps3 or pc the whole stick works fine. Does anyone here have any clue as to what could be causing this? If it matters i am using the stock pcb in the stick. I believe it is the 4-20-2009 model mayflash stick. ie. the non common ground one.


#2

its very likely the previous owner plugged it into both consoles at the same time and broke it. this is a known problem with that black mayflash PS2/PS3 joystick. I have no idea how good you are at mods. before you go and blame the seller, you should double check your work with a multimeter. also, it would have been nice if you actually tested the stick before you started modding. now you really don’t know who broke it.


#3

There was no previous owner, i bought it new. I got a good price thanks to some trade in and returned items. Don’t assume things my friend, i did indeed test the stick before i modded it. It worked fine with both consoles before i modded it. I wouldn’t say i’m an expert at modding, but i have modded around 40 to 50 sticks over the past 2 years for friends and people in this area, and a few mods of my own. The stick does work fine on ps3 and with adapters as i mentioned before.

After i finished modding it i tested the stick with GGXX AC+ on ps2 and it worked fine for the 20 minutes i played. The next day there were no directional inputs when it was connected to the ps2 (still works fine with ps3 and pc via usb or ps2 adapters) I am not blaming anyone, i just want to know what may be going on. I would guess that it may have something to do with the voltage since usb is 5v and ps2 is 3.something but it did work originally on ps2 perfectly. Also i never plugged it in to both consoles at once


#4

Set GGAC+ controller settings to Analog on if you have not already. For some strange reason the PS2 side of the PCB operates on purely analog outputs despite being designed for fighting games.


#5

i’ll have to try that. Though i wonder if that’ll solve the problem with every other ps2 fighter i have though.

*edit: i have no idea what was going on but it’s working fine now with all the games i’ve tried so far. hopefully it stays that way.