MC Cthulhu Problems with PS2

Hey all, I’m having a problem with linking up my MC Cthulhu stick to my PS2. I assume the problem lies in the cable to the console because the stick works with the Dreamcast and Saturn Cables I made just fine. The thing is, with the PS2 cable, I’ve tried and tried to no avail. I happen to have the same wiring set up in my PS2 cable as Rtdzign’s does in his RJ-45 tutorial…

RJ-45 Multi Console Cthulhu Arcade Stick Tutorial Ver.2

…but after using a regular ps2 controller’s cable, an extension cable, and going through five ethernet jacks I was wondering what I might be doing wrong, or if there’s any common problems relating to the PS2 cable.

By the way, I’ve rechecked the signals of the wires to the controller port end. I’ve made sure that the prongs on the ethernet are going through the wires after crimping. I’ve made sure the ethernet casing is still covering part of the outer sleeve of the wire after crimping. I think I’ve checked everything. But it has to be this specific PS2 cable, and not the inner wiring to the Cthulhu, right? That is, since the Dreamcast and Saturn cables I made work fine.

not wanting to sound like a dick, but originally was the pad working? was the extension plugged with a normal pad working?

trying blowing the ps2 and the end of the cable maybe its dusty?

maybe i dont know what im talking about? sorry.


I have had a similar problem in the past with a TE Kitty on a slim silver PS2. I’ve literally changed everything: cables, jacks, etc. I’ve even worked with Toodles to try and find a solution, and he was stumped as well.

PS2 cables are the most difficult to do properly since they have 7 wires. If you have detachables cables, you could also double-check the wiring at the jack.

You said you checked the signals at the port end, did you use a multimeter or did you pop the ps2 plug apart to figure out the wire pattern? If you popped the plug open, maybe recheck that and make sure nothing is messed up there.

Thanks everyone for the answers! Anzhar you’re fine, you don’t sound like a dick at all. It’s not strictly limited to the gamepad, I think, as it works on the DC and Saturn just fine, but maybe just for the PS2? Also, I did use a multimeter skrawney, but still the signals aren’t lining up. As far as the 7 wires, I thought the Saturn was fine even though it uses all 8 of the inserts on the ethernet jack (as opposed to the the 9 wires it actually has in the cord), but it must be too hard for me because I can’t figure out the problem for the life of me. I’m down to two ethernet jacks left and I’m seriously debating whether I should buy a premade ps2 cable from focus attack to see if it’s just the gamepad or me being stupid…

IF the wires are conducting electricity the way they should, then it’s definitely NOT the cable.

You have to check each wire individually and BE SURE that you are touching the right ends. It’s very, very easy to miss touching the right spot for the wires in the PS2 adapter plug… It was one of the harder cables to convert for me. The console plug-ins are always a pain in the butt to check for electrical signal transmission – the PS2 and Saturn are by far the worst in this regard (although the Saturn gave me less troubles than the PS2… probably because the internal wiring in the Saturn cord was thinner and slipped into the RJ-45 assignment slots more easily).

Also, you have to check every PS2 cable you intend to mod. You CANNOT depend on the manufacturers for consistency because they changed wiring assignments all the time for PS2. Hori would be one company to be wary of since they have produced a lot of joysticks with “unique” arcade button layouts that aren’t the same as the regular SF II button set-up.

IF the Saturn adapter cord worked then it’s also NOT the MC Cthulu because it’s obviously conducting electricity through every circuit/data transmission point.

At this point in time, I’d try to mod another PS2 cable or buy an RJ-45 modded one online. You probably just ended up with a dud cable unfortunately… Only other thing I can think of is that one of the wiring assignments in the RJ-45 is wrong. There’s a line in the PS2 cable that’s “null” and doesn’t transmit data per se and Toodles’ MC Cthulu doesn’t need this line… you can cut it down so that it doesn’t interfere with putting the other signal lines into the RJ-45 adapter. It is possible that you’re using the null line by mistake in the -45 head.

Yeah, I think I’m going to buy one online, because I’ve quadruple checked my wiring and used up all of my ethernet jacks. I’ll report back on whether or not it works for future reference, as mistahsnart seemed to have a similar problem.

I have a similar problem with my new MC Cthulhu!
Its revision 1.4 and I upgraded the firmware to 2.3, and I built it as a RJ45 port and different cables according to this thread: RJ-45 Multi Console Cthulhu Arcade Stick Tutorial Ver.2

It works fine on PC with the USB/RJ45-Cable.
It works fine on Dreamcast with the DC/RJ45-Cable
It works fine on PC with a PS2<->USB Converter and the PS2/RJ45-Cable.
but it does *not *work on the PS2 itself! Just doesn’t respond.

I tried shorting or not shorting the “Home”-Button to ground, but it made no difference.

The PS2 is one of the later Fat models and equiped with a modchip, but I don’t know the kind of modchip.

Has anyone an idea?

With the MC Cthulu, you must be sure that your firmware is up-to-date…!

When I bought my first MC Cthulu (2009? 2010?), there were still some troubles on the PS2. Mainly dealing with games that had some emulation in them like Street Fighter Alpha Anthology. The simple way to deal with that back then was to unplug and then re-plug the joystick in after the game loaded.

Toodles corrected the problem shortly with updates to the firmware.
As of my latest check, I don’t think the Firmware has been advanced past 2.3 so obviously the chip is working well with most everything. It still has more retro-system support than anything else on the market and is one of the most reliable chipsets out there. It’s what I have for all MAME/emulation that I do on my AMD PC as well as the consoles when I power them on for gaming…

I can’t speak to mod chip PS systems but there could be a potential hardware conflict there. What I have are three Slim PS2 models so I can’t speak to the original Fat design. All I’ve ever done with my PS2’s is a little clipping and shaving of metal and plastic so that I can run JP-NTSC games with the Swap Magic disc. I’m not going to pay someone to solder a chip to the insides of my PS2’s or even attempt that on my own. Safer, reliable alternatives exist.

What with the emulation getting better for PS2 on PC, I don’t think we’re going to have conversations much like this in the near future! It’ll be a moot point and most PS2’s if they haven’t been dumped will probably go up in personal mini-museums like some people already have of the joysticks they’ve bought.

(Now if someone had told me we’d have near-perfect emulation of the Sega Saturn on the PC on the horizon a few years back, I would have laughed at them… It’s happening, though!)

I only tried the 2.3 1ms firmware, because the readme states, the 1ms/10ms difference only has an input to usb-cables-uses on PC and PS3. Or is there also a difference to the response on PS2-systems?
As it doesn’t cost much time, I’ll simply try flashing the 10ms-firmware and then plugging the stick into my PS2 again. And I also try this unplug/replug after the game is loaded trick. Thanks for the input.

Finally I got a chance to test my custom built stick at a friends PS2.
Same problem: no response at all. Even unplugging/replugging after the game was loaded changed nothing.

I really don’t know what the problem could be! The cables are fine. I tested the Stick with two different ps2/usb-Adapters. These adapters recognize the Stick at once on PC and even on PS3! So the MC Cthulhu seems to switch to PS2-mode as expected - at least if plugged into such an adapter.

But it does not work on a real PlayStation 2. I checked with my modded fat PAL-PS2 (and thought the modchip could pose a problem) and therefore yesterday I tested on a unmodded fat US-PS2 at a friends place.
Sadly, the stick did nothing.

Is there any special wireing required? Or do I have to press any buttons on the Stick, so it is recognized by the PS2?

Anyhow, it has the 2.3 10ms firmware at the moment. Has anyone an older firmware for me to test? perhaps it works with an older firmware. I am out of ideas :frowning: