McCthulu Arcade Stick recognized, but no Inputs!


#1

Hey guys, so I have this McCthulu+RJ45 modded TE stick that was fine until very recently. Last week, I tried to play USF4 on steam and my computer said that the usb device has malfunctioned which meant that it wouldn’t be recognized. To test if this was a PC problem, I tested it on the ps3 and the controller still wasn’t recognized. After some fiddling with my rj45 cable and neutrik port, i realized that if I jiggled the cable correctly, the stick would be recognized, leading me to believe that it was a problem with the neutrik port. I ended up ordering a new neutrik port and a rj45 data connector just to solidify my connection so that it would be more robust.

Fast forward to today and my items have arrived and I install the data connector and tried it out-- to my surprise, the stick works and the inputs are recognized! I try it out in training mode and everything seems back to normal. I didn’t even bother installing the new neutrik port as I figured that it was fine. A few hours later, I decide to play online and while the device is still recognized, there is a huge problem- none of the buttons or joystick seem to be registering any inputs! On the device list the stick is listed as MCCthulu and XPadder recognizes the stick and pulls up the default control settings, but none of the buttons register when I press on them. I ended up replacing the neutrik port just to see if it would work, and the problem is still there. I tried it on the ps3 and none of the buttons/joystick work either… I am skeptical that it’s the neutrik port’s fault, and I’m also skeptical that it’s the rj45 cable as I just bought this one last month. I tried to update the firmware, but since the inputs from the stick aren’t registered, I can’t hold down start and select.

At this point I’m not sure if it’s a hardware problem or a firmware problem, but I really need your guys help on this as I haven’t played in FOREVER.
Thanks for the help!


#2

Update:
So I just plugged it in an started USF4 and noticed that the game recognizes the controller, but like I said earlier, it doesn’t recognize the inputs whenever I press anything. Any ideas? I tightened all of my quick disconnected wires and made sure everything else was snug. Is there a certain way to wire QC wires for buttons?


#3

what I would do:

remove all wires from QD’s

cut/restrip each wire and then tin the ends with solder (I do the same with home stereo stuff)

Test with multimeter

reinstall.

of course I would do that AFTER trying a different cable…, new or not it could be the culprit.


#4

So I don’t have a soldering rig, but I tightenened all qc’s and used a multimeter- it works! However, like I said, the computer and PS3 still don’t register the inputs when I press a button. The buttons ARE recognized; I can see McCthulu on my control panel and when I start up xpadder, I can see all the buttons and the keys mapped to. However the problem is still the same-- when I press a button, no inputs are registered in the computer!


#5

Control Panel -> joy.cpl doesnt show button presses?

you may have to triple-check wiring :frowning: it’s strange for a cthulhu to stop working unless you have a faulty dualmod


#6

I don’t completely understand. You should probably check the ground line. If that is bad, none of the buttons work.

Do the directional controls work?


#7

What is the ground line? That could potentially [hopefully] be the cause of my problem. I just looked at the game controller properties on the control panel to see if anything was being registered. Like x padder, windows sees the buttons, but when I press on any directionals or buttons, none of them flash to indicate that they’ve been pressed.


#8

Your ground wire, the wire that provides return voltage to every button and input on your Cthulhu PCB.
Every button has its own signal wire and the ground is daisy chained and wired to one of the many GND or Ground terminals on the Cthulhu.


#9

Yes, it was the ground wire! I tugged on all of the wires on the mccthulu pcb and lo and behold, the ground wire was loose!
Thanks for the help guys!