MCZ TE Rd 1 Dual Mod Joystick/ Jab Button Intermitant Issues...Help!


#1

I have a Mad Catz TE Round 1 Xbox fight stick dual modded with a Chimp PCB for PS3.

I was at a tournament last Thursday where we were using both Xbox and PS3 for different games.
On the Xbox systems my stick worked perfect, but when I switched to the PS3 systems the left position on my fight stick wouldn’t work, but when switching back to Xbox it worked fine.

I took it home, where I only have a PS3, to find the left position still not working. I popped it open and jiggled around some wires on the Chimp and it worked fine on the PS3 all night during a 2 hour casual session.

On Saturday I was at a casual meeting where we were using Xbox systems and after about 1 hour of play the jab button went out, not a big deal, has happened before I know how to fix that. Took it home to find the jab button now worked fine on my PS3 system, but my left position was out again. I spent about 30 mins messing with it last night to only be able to get the left position to work for about a minute at a time till it would go out again, without and adjustment to the wires. I then took the stick position solenoid, not sure what that’s called, out to not find and physical problems with it.

Now I’m stuck trying to figure out where the problem is. Is it the left solenoid piece, which I know I can either replace individually, or replace the entire piece. Or is it something with Chimp PCB, which I’m unsure if this is a common issue with those or not. Was the jab button an anomaly or is it also related to this issue. Since I don’t have a Xbox to try it out on I don’t know if the left stick position works on Xbox as it did last Thursday or if the jab button is still inoperable on Xbox as it was last Saturday. I won’t have any opportunities to test it on Xbox til next Saturday at one of our bigger tourneys in Seattle where I need/ want to have it working 100%.

Anyone had similar issues before with this same setup? Anyone have a chain of tests that I can narrow down the issue?


#2

Seems to me that some of your wiring is loose.
Who did you mod any ways?

Also photos of the insides will be helpful.


#3

Can anybody tell me where I can find a ChImp PCB so I can dual mod my Mad Catz stick?


#4

The left direction problem you already nailed down; it was a loose wire. The jab button might be the same, but or might be the button itself dying. The best thing to do would be to redo the wire connections to the Chimp, so they’re soldered in place instead of going to the screw terminals. Replacing it with a Kitty is an option as well, but only if youre afraid of soldering. If you’re comfortable soldering, just do that to secure the wires to the Chimp permanently.

You can always get them from yours truly. http://gdlk.co


#5

Thanks for the responses.
Under more thorough review I have narrowed down the issues.
I have tried a different joystick assembly with this board and still have the same issues, I also tried to change the wire which is connected to the joystick assembly to the area highlighted in the photo below.

I would agree it sounds like a loose wire, but with how intermittent the issues are I think it is something more serious. Sometimes when I unplug the replug the joystick wire it works for a minute or two. I intentionally don’t move any of the parts to avoid any wires having the posibility of moving. If the issue wasn’t so consistent in its timing and worked until I closed the case up, I would also believe it was a loose wire.

A local guy named Lee Acacio, who is on these boards but don’t know his screenname, did the dual mod and I have contacted him for help.

I’ve included 3 photos, not sure what you would like to see from the photos, so let me know if you need close ups of anything or if you need to see the backsides of the boards.

Here is where the wire I have unplugged and replugged in to have limited time functionality.

I also thought that this is where the loose connection might be and unscrewed this panel to realize that the connectors all looked tightly in there and waxed closed.

I believe all the connections to this board are on the bottom. Let me know if photos of the bottom are necissary. Sorry this photo is blurry, I took it with my camera phone. If needed I can take this to work and get better photos, I work at a camera store.

I replaced the button and didn’t have any further issues with that on Xbox. I just thought that it was weird that it didn’t work on Xbox but did on PS3, while the stick works on Xbox but not PS3.

Are the screw terminals on the bottom of the black board? I can’t seem to see them. I might also have been misinformed as to which board this is. Maybe its not a Chimp, that’s what I was told by the person I bought it from.

How would I check to see if the wires are already soldered on? What are my options if they are?

Please let me know if more photos are needed and of what you need photos of.

Sorry for the delayed response, I needed time to take photos and answer the questions posted, all while being an active competitor in the FGC, had a tourney on Saturday, where I got bodied by Air in winners, then had to face my roommate in losers in SF4, vids below, fallowed by a ranbat that evening and spent yesterday in the lab with SFXT.

[media=youtube]AZIsBY-Ic-k[/media]
Air vs me, still learning Sakura and this matchup, my main is honda, but honda v ryu is pretty bad, especially vs Air.

[media=youtube]CyVZe5AzOBY[/media]
Vid of me vs Seattle’s best Ken player

Thanks for your help.


#6

The black PCB is indeed a ChImp.
ChImp v1.1 really.

Your guy bought the ChImp as a kit.
In so, he did not solder on the Screw Terminals.