Measuring GGPOFBA Micro Stutter


#26

Does Win8 come with DirectX installed? Are there any compatibility settings?

It sounds like it’s using software rendering rather than hardware acceleration.


#27

Im not sure exactly im not particularly computer savvy myself. As far as I can tell the problem is, when ever GGPO fucked up on my old vista cpu. I could right click the display settings or whatever, and for some reason the cpu would be in 32 bit mode. Then I would switch it back to 64 bit and the graphics etc would be fine. Now with windows 7 and 8 it seems it just automatically sets everything to either 32 bit or 64 bit. And ggpo no matter what I do will always run in 32 bit mode with though I have 64 bit windows 8. I cant seem to find any option to switch this now like vista. Ive tried searching online as well and havnt been able to find a answer either. Ive tried messing with all the compatibility settings that I can think of off hand too. Bummer.


#28

Not sure what the problem is, but 32-bit binaries will not run in pure 64-bit operating systems. The only they to accomplish that is to actually have multi-library system that will have both 32 and 64-bit libraries so as to be able to run both kinds of files. Windows will never run GGPO is 64-bit mode if the file itself is not 64-bit.

Now since Windows does not have a file command (unlike *nix operating systems), I decided to download the latest version, decompress and run the command on them. Here’s the result:


$ file *
META-INF:           directory 
assets:             directory 
css:                directory 
fonts:              directory 
ggpo.exe:           PE32 executable (GUI) Intel 80386, for MS Windows
ggpo.swf:           Macromedia Flash data (compressed), version 10
ggpoair.exe:        PE32 executable (GUI) Intel 80386, for MS Windows
ggpofba.exe:        PE32 executable (GUI) Intel 80386, for MS Windows
ggponet.dll:        PE32 executable (DLL) (GUI) Intel 80386, for MS Windows
kailleraclient.dll: PE32 executable (DLL) (GUI) Intel 80386, for MS Windows, UPX compressed
mfc80u.dll:         PE32 executable (DLL) (GUI) Intel 80386, for MS Windows
mimetype:           ASCII text, with no line terminators
msvcr80.dll:        PE32 executable (DLL) (GUI) Intel 80386, for MS Windows
savestates:         directory

So the files are 32-bit and cannot be run in 64-bit mode.


#29

Dunno what to say then because thats how I got it to work in my 64 bit vista. Graphics were clear, but everynow and then my shit might bug out. And it would reset and it would say its in 32 bit mode again. And ggpo would be super pixly. So I would right click display and set everything back to 64 bit. And it would be fine again. Doesnt seem to work like this though anymore in windows 8. It automatically sets everything to 64 bit or 32 bit and I can not choose it manually anymore.


#30

Try downloading a DirectX update, although that may not help. Do you know what your video card is? If it has a control panel with program specific settings, you might be able to force it to do some stuff like running in a compatibility mode.

There’s also Windows compatibility settings, although I question how much of an effect they have. It can’t hurt to try -


#31

My results from speccing a Hong Kong to Japan Vampire Savior match:

I am running ggpofba in Windows 7.


#32

Sorry I’m late to this thread. Delatroy just pointed me to this.

Here’s what I understand so far

The latest shipped version of ggpofba is 0.2.96.74

The source code ponder released is http://ggpo.net/download/ggpofba_0.2.96.71.zip

Unless he made actual improvement to the ggpo.dll, he probably just port the fba diff from .71 to .74.

If not, we’ll have to ask ponder for the latest ggpo.dll. He’s 24x7 with his latest startup along with his brother and friends, but I think he’ll eventually respond.

Now, I read the fba building instruction from http://neosource.1emu.net/forums/index.php?topic=2379.0

The latest fba is http://www.barryharris.me.uk/files/fba_src_029729.7z
http://www.barryharris.me.uk/fba.php

Jugoso, what changes have you made to the github fork you have there, can you already build it with the GNU tools?

Updating ggpofba.exe could be feasible depending on whether the latest fba made some big architectural changes, and whether the up to date ggpo.dll is contained in ggpofba_0.2.96.71.zip.

We’ll also need the vanilla fba 0.2.96.71 source code so we can diff against ggpofba_0.2.96.71.zip, and port those diff to the latest fba.
I tried to see if they keep old source tarball in the same location but nope
http://www.barryharris.me.uk/files/fba_src_029671.7z

Do the maintainers (CaptainCPS-X , Treble Winner ?) have a official code repo on google code, source forge or github?

What rom set you used ? I downloaded latest fba64_029729, neither the existing ggpo rom set nor the shmupmame st romset worked :frowning:


#33

In case people missed this, Zinac released his networking code on the MIT license.


#34

How good is it? Where is it used?


#35

In the game he’s working which is in public alpha(Fearless Night).
Me and MightyMar have played each other on it, the netcode is really good.

Edit: It allows a rollback style netcode. Which I should of stated on the first post.


#36

This is normal because the mame rom set updated since the 2008 GGPO FBA release. You can combine your current ssf2t.zip and ssf2tu.zip and it should be fine.

See here: http://neosource.1emu.net/forums/index.php?topic=2436.0


#37

cool. i’ll give clrmamepro a try

fba64_029729

Besides the lax licensing term of FBA, why haven’t people looked into implementing good quality net code in better emulators like groovymame or shmupmame? Do you think it will be tough to integrate ShobuNetwork with mame as least for p2p style connection without a match making service like ggpo.net?


#38

Well each system uses a different savestate setup and some systems don’t even have savestate supported on Mame. So not all games could be supported. If it was going to be done you have to focus only on a few systems at first.


#39

FYI antervud found the vanilla source of
http://www.barryharris.me.uk/files/fba_src_029670.zip
http://www.barryharris.me.uk/files/fba_src_029672.zip

but for some reasons they don’t have fba_src_029671.zip

anyway the latest ggpofba is 029674 and they do have the vanilla source of that
http://www.barryharris.me.uk/files/fba_src_029674.zip

I just took a cursory glance of diff between fba_src_029670.zip and ggpofba_0.2.96.71.zip
It wasn’t too bad but not trivial either.

However the bad news is the diff between fba_src_029674.zip and the latest fba_src_029729.7z
They reorg a lot of code. So really need someone very motivated to do the port, given that ponder will give us ggpofba_0.2.96.74.zip (which according to license term of fba he should, but he’s extremely busy)


#40

this should be the release immediately after the frame fixes (apparently they skipped a code release to protest against some unofficial versions teams that don’t wanna release source code)
http://www.barryharris.me.uk/article_view.php?id=152 (0.2.97.09 Release)

maybe this has less code reorganization

you can see captain-cps claim that in this thread
http://neosource.1emu.net/forums/index.php?topic=1482.msg11622#msg11622

edit: this is the nearest available http://www.barryharris.me.uk/files/fba_src_029713.7z


#41

You think you guys could modify FBA to run 3S at an arcade perfect level?


#42

Been a few months since I posted any new ideas on how to get ggpo to work on windows 8 yet? Im thinking I may just have to give up the idea of ever playing online again. Tried to play again and its just fucking awful… Super pixly all jacked up, and the lag delay is just awful. Getting hit by jump random jump ins cant even block let alone try to do moves. Bad enough I had to play with a broken controller the before… Time to retire for good at this rate lol Its like even small pings are not equivalent too 200+ it feels liek at least.


#43

Dual boot to XP and hope it’s not as bad, since video card support of older DirectX calls seems to be a major factor in whether and how much it’ll skip frames.


#44

Doesnt that work the opposite way though? Like when I had windows vista I could easily run things in XP or whatever… But this isnt like vista or XP that I put windows 8 on to go back… I got a new cpu and its just windows 8 period. So when I try to change the operating system the only thing I have period on this cpu that I can use is windows 8. Before I could do something but not now. At least that im aware and have tried/fiddled with. =[


#45

It’s still possible, but it might take a bit of time to set up. You’d need a new partition for XP and a bootloader like EasyBCD (free version), as well as making sure there are even drivers for your stuff on XP.