Messed up QD in HRAP2 :(


#1

I’m usually not the type to make a new thread since I’m a regular here and I should know this stuff… but I can’t hold out anymore, lol.

So one pair of quick disconnects on my HRAP2 has become unresponsive. The problem is pretty simple actually: The button that’s connected to the pair works, but then stops after a few *seconds *of play. Simply removing and replacing the pair of QD’s will just reset the process. (Though not always.)

I admit that I have done a lot of modding and haven’t always kept the wires in the best condition. (So it probably isn’t a defective PCB.) But what should I do now?

Obviously the simple thing is to just swap the QD pair with a button that I don’t use (like using R2 for triangle and vice versa), but I want to use that as a last resort. First of all, is it even possible to find out if one or both are the source of the problem? Second, would cutting it and then re-crimping it help? Any info you guys have would be helpful!


#2

And yeah, I already tried different buttons to make sure that it was only the QD’s.


#3

If the QD’s are making contact on both ends, and you’re sure it isn’t a PCB problem, then the problem is probably in the wire itself. Try soldering on a new set of wire in that case with new QD’s. Likely to not cost you anything(pretty much spare parts lying around somewhere since you’re in Uni) and will be better in the long run.


#4

PCB issue, then. Or maybe it’s the wire? Do some of the common testing for us to help diagnose the problem.

Cutting it out and recrimping might do the trick too.


#5

have you tried taking a pair of needle nose pliers and tightening up the QD’s?


#6

I overthink things. : (


#7

Thanks for the responses, guys. Just to reiterate, the QD’s *work *for a few seconds, and then die out. Replacing them after a few tries just resets the process.

You’re right that it may be a contact issue. I would totally replace them but I don’t have the capacity to do that, heh.

I mentioned re-crimping in my post, but I just want to know what else I can do. And what do you mean by “common testing”?

I’ll give that a shot in a while.


#8

OK so I tightened the hell out of it and it started working, but now it’s stuck on activated even after I take the button out, lol.

After it stopped being on activated, it just stopped responding altogether. And now it’s responding again, lol.
**
So in short, it’s on again / off again regardless of tightening.** But any slight adjustments causes a drop in inputs. So there’s something wrong with either the QD terminal or the end of the wire…


#9

youve got a problem with your pcb my friend… either that or a loose connection where the wire meets the pcb


#10

Thanks man. While I can understand the latter, the former can even be true if just *one *button is not responsive? I’ve tested the others and they’re fine.


#11

Did you take a multimeter to see if there’s a short on the pcb for that button?


#12

Huh? Sorry I don’t have one of those. Are they expensive?

My next step is to re-crimp it with a whole new terminal. So do I just cut the wire a few mm down and then peel back the covering?


#13

$10 at Radio Shack. Could be had even cheaper on line.


#14

I actually have a confirmed short on my PCB for the RB button on my SE fightstick. Even when all of the QD wires are completely removed from the stick (buttons are disconnected), the stick registers that the RB button is being continuously held down. I have determined that the problem is in the main PCB (by basically disconnecting every wire leading to the main PCB and having the same problem).

If I do in fact get a multimeter, can the problem actually be detected and fixed? If so, what would the process be in fixing it?


#15

I had no experience prior to my own mod last month so I figured out things fairly well.
I would use the multimeter to touch both of the connections on the pcb, If it detected continuity, something is wrong.
Check to see if maybe a piece of wire from one half of the button is touching the other half, completing the circuit. I had some of the zigzag connections on the pcb and soldered badly and it went over and covered both sides. I just took an xacto knife and just sliced at it till it separated.
So just double check something didnt fall on the pcb and bridging it. i dunno. take pics maybe.


#16

Cool, I will see if I can take some pics of it today. I have class for a few hours now, so it might not be for some time, but PLEASE take a look at this topic after this weekend at the latest, lol. Thanks a ton for any future help you can give me.


#17

It’s probably the connection to the PCB, or the button itself. Why don’t you try just touching the two QD’s together at the tips and see if the button activates? If it doesn’t, then you know your problem. If it does, same.