MK not registering on EX2


#1

Hey guys, I bought a custom stick from a friend today, but MK and fierce were not working. I opened the case when I got home and see that the wire going from fierce is just lying there, so I strip off some wire and put it into the terminal strip, and low and behold it worked!

I also saw that the wire for MK in the terminal strip was very loose, so I removed, stripped off some, put it back in, but still no go =[

Any ideas why MK is different/not working?


#2

The EX2 is a POS


#3

Only used an empty EX2 case so don’t get your point

Besides, don’t post if you’re gonna post bs, real answers only plox


#4

I did not post BS. I posted a truth.


#5

at first I thought this thread was about Mortal Kombat because Tim Static posted in it last. w/e.

take detailed pictures of the guts, and post it. prolly really bad soldering job done on the pcb


#6



PCB not visible in pics but there are no fault as far as I can see with PCB wiring. Like I said I insert the MK wire into the terminal strip, but no go. When I was stripping the wire I think I may have cut some of the wire too, but I doubt thats it since I took it out/re-stripped to match the fierce. Put it into the strip, and no go


#7

make sure that both ends of the wire in that designated column has enough exposed wire so it can make an electrical contact with each other.

i’m just pulling this assumption out of my ass, but it looks like your friend done the ol’ solderless method to a pcb. if it is wired that way, make sure that every wire is firmly inside each pin on the pcb.


#8

Hi, I tried that, no luck. However to be sure, I placed the wire going from the MK QD into another slot on the terminal and it doesn’t work.

For example, I put the wire from fierce into the MK terminal slot and it works fine, shows up etc
When I put MK wire into ANY other terminal slot it doesn’t work, not for one button

if I switch wiring and qd from two butons, mk and anything else, one will work, mk wont

*no matter the terminal slot

So it can’t be the ribbon strip as far as I can see

Any ideas?


#9

When in doubt, throw it out. (the MK wire I mean, not your entire stick) Pull the MK wire out of the PCB. Did you stuff the wire in the PCB ribbon connector membrane? That may be the culprit.


#10

Stuff the wire?

How would it be the ribbon connector, when other wires work in the MK slot?


#11

Bump

Ok so here is my guess, it can’t be the PCB ribbon strip wiring. Here’s what I tested

  1. I took the wire (orange) from MK, and placed it into other terminal slots (I tested it on ALL other 5 face button terminal slots and they all worked =/) My assumption at this time was that the slot MK was in had a loose connection on the other side, so I tried wires from other buttons on it

  2. All said wires worked fine, apart from MK. What does that mean? To me, it means that the terminal strip is working fine and can be scratched, all the other 5 face button wiring is fine too, so that can be scratched

  3. I even changed buttons and QDs around and got similar results, all other 5 buttons worked in any terminal slot, but MK (orange) refused to work on any button or terminal slot

So to me, if all other 5 buttons work, it cant be the terminal strip therefore it cant be the ribbon strip

Any ideas guys?