Moledcule: Kaimana Theme Builder, Compiler, Flasher... ...you design... ...we code!


#44

You can rearrange your wiring by dragging the order around under the configuration section. What you have done is a good first step in creating a theme in the colors section

I’ll post a video later


#45

I’m on a standard Kaimana.

Moledcule recognizes it as a USB device.

I put in my wiring order, flash my device and it’s wrong. Every time.

Do I need drivers?

I set it for Kaimana - Led Joystick - Fade on

  • 8 buttons

No luck.


#46

please sen me you
link to your theme
if you take a look here at the [color=#10cfbd]themes list and select your theme. send me the link

it would look something like this
[*] http://moledcule.club/#/themes?theme=582c65c0f7964c2c9bc0c900
[/color]


#47

Here it is.


#48

thanks.
remove the balltop

for now, balltop support is kinda wonky and we are working on it.
simply remove it from you configuration and test that


#49

If I remove the ball top from the sketch, it’s still in the daisy chain.

To get this to work I have to physically disconnect my ball top?

Is there a way to add the fade effect to the standard Kaimana sketch, or export the code for use in an Arduino Leonardo program?


#50

Im using a PFS2.0 w/ a Khameleon. Using Jasen’s boards, what order do I need to put the buttons under wiring order?


#51

Who’s talking about balls
Balltop LED in v1.0.3
That’s right.
After a long delay (sorry, have a FT job now), the almighty balltop color selector is now available!


#52

Nice. Will try it again.


#53

It’s all about to compile
Balltop Hot Fix in v1.0.5
fixed a small compile bug


#54

Fash Original Code
Kaimana Restore - Fix in v1.0.6
fixed a bug that did not allow you to reflash the original Kaimana base code


#55

Options Select
Updated Modes

[media=youtube]uNv1agDAxIg[/media]
Hey all, as per popular demand we have added more selectable modes.

To select a mode, you will hold a direction, and a button combination for 5 seconds

Modes

Moledcule (UP + P1)
This is the theme you created using the configurator

Tournament (UP + P2)
All light off

Solid (UP + P3)
After you see the lights light up solid color, release everything and then pick one of the displayed colors

Screen (UP + P4)
This is the screen save mode (crazy lights all the time)

XBOX (DOWN + P1)
XBOX Controller Theme Style

Playstation (DOWN + P2)
Playstation Controller Theme Style

TVC (DOWN + P3)
Madcatz TVC Stick Colors

Available now through http://moledcule.club


#56

Is there anything special you have to do for a hitbox setup? It seems to not save any of my wire orders and just has them going to random spots. Using a UFB with a kaimana khameleon on win10 if this helps.


#57

Take a look here
https://youtu.be/fS_z9_u8IUc?t=52

You need to open the “configuration” panel and drag your buttons around to the appropriate order


#58

I’ve moved it around in the config and what it shows in the vid but it never seems to match what I put in the order. Buttons will be off by a bunch and I’m following the order I put the kaimana khameleon.


#59

Mentioned this on twitter, but I haven’t had any luck flashing at all. I’ve attempted to flash on 3 separate computers, 2 on Windows’ Creator Update.
This worked before I just can’t figure out why it doesn’t work anymore, even attempting to flash using Arduino’s software hangs at flashing.
I recorded a video of what happens:


#60

I’ll take a look when I get home


#61

Hey, so i watched you video a few times.
Can you do something for me.

You start hammering the buttons right away after the flash.
There is a default 8 second timeout on the ATMega32u4

When you flash it (even with the kaimana, the successful part), WAIT until you hear the USB dinging. DON’T start hammering the buttons.

So…

When you flash you will see a few messages

  1. Attempting to reset current device
  2. Successfully reset current device
  3. Device connection and handshake
  4. Please Wait

After the initial set of messages you will get

  1. Your device has been successfully updated
  2. Your device will restart in approximately 8 seconds (Please DON’t hammer the buttons, just wait)

Once the Kaimana sends back the reset signal

  1. You can now safely unplug your device

#62

I’ll try after I get back from Evo, still I remember waiting a long time in the hundreds of times I tried, but the issue persisted.


#63

This was actually the same issue I was having. The buttons weren’t matching up and had issues resetting the kaimana as well. I was using a hitbox setup so it could’ve been other issues as well.