Multimodded stick stuck in "up" direction when plugged into Xbox 360


#1

OK, this is a really weird problem-- I have a multimodded stick with an MC Cthulhu, Imp switch, and a Chinese Xbox 360 PCB. Two of my room mates have Xbox 360s-- one is an Elite, and the other is a pre-HDMI Pro model. When I plug it into the elite, the stick works perfectly. However, when I plug it into the Pro, it is stuck pressing in the “up” direction and will not stop unless I’m pressing “down” on the stick. It also works fine when I plug it into a PC and load it up in Xbox 360 mode, so I have no idea what the source of the problem is. I even tried hooking it up via my PS1 cable running through my Playstation adapter tethered to an Xbox 360 gamepad, and instead of “up” being jammed, the “guide” button was jammed.

Any ideas as to what the cause of the problem could be? I tried all 3 USB ports on my room mate’s Xbox 360, so I can rule out it being a bad USB port, and since it works on the Elite Xbox 360 but not the Pro, and the problem is inconsistent depending on how the stick is connected, I think it’s safe to say it’s not because the Cthulhu or Xbox 360 PCB are not responding, so this is probably a problem with the Xbox 360 itself. Any ideas?


#2

Xbox 360 Pro “hic-up-ing”


#3

Me and my roommates are starting to come to the conclusion that my roommate’s 360 is just plain screwed up somehow, but we’re not sure. There are a lot of quirks about it and it might be that it’s just entering it’s senile years, but I’m not sure.


#4

Did you try another wired controller