Multiple Issues on Different Sticks


#1

I’ve got three different problems I want to fix here:

  1. I have a Qanba Q2 (PS3 Version) which suddenly doesn’t work. When I plug in the USB, the lights faintly flicker (so faint, you can’t see the original blue colour, but can tell it turned on), turn off completely and then nothing happens. The stick also doesn’t respond to any button presses and when plugged into the PC, the stick isn’t shown on the control panel (not even as unknown device). So I attempt to replace the USB cable by exchanging it with the Q4 I have…and still the same problem. I take out my multimeter to see if there’s power on the stick. Sure enough there’s power. I try unplugging all the LEDs and still nothing. Anyone know what’s wrong?

  2. A friend’s TE Round 1 automatically presses down when I plug it into the PS3. So I open it up and disconnect the JLF. Still occurs. I take a test meter and check the voltage between the VCC and Down and sure enough the voltage is lower than on the other directions. How do I fix this? I heard it has to do with a resistor being installed. I recall seeing it somewhere on Phreakmods website but couldn’t find it.

  3. PS360+'s on TE’s. So everything works fine. However when I hook up the PS360+ to the TE’s turbo panel for home button functionality the home button gets pressed while in-game. It does it pretty randomly too. The home button works as it should when pressed.


#2

On problem 3, the easiest fix would be to disconnect the home button altogether and use start + select as home.


#3

I know that much, but that button combo doesn’t seem to work on a 360 however.


#4

It should if you’ve updated the firmware. I use one on a 360 without a dedicated home button.


#5

Alright, but I’d still consider this “fix” as mitigating the issue and not really fixing it for the given configuration.


#6

for #1- i had pretty much the same issue w the flickering and non-functioning. Hopefully you are still within 60 days of your warranty, send it back to 8arc , its their USB wire


#7

For #1, it sounds like you have a short somewhere between a ground and the signal for your home button. Check the entire path inside of your stick, manipulate the wires, and see if you can’t recreate the problem.

For #2, You likely have another short. When you check analog signals for issues like these, it is much easier to probe between the signal and ground and you do not need power to do so.

Your hypothesis would be incorrect unless there was still a significant voltage (you were probably seeing microvolts, which is essentially grounded and not the work of a resistor).

Assuming your hypothesis is correct, you may have a redundant resistor left over from a previous mod. Follow the signal all the way to the chip and see if there is one, and remove it. It could also be that you have faulty wiring which is adding resistance to your circuit, but that is even less likely the case.

For #3, you have yet another intermittent short. Follow the signal and try to replicate the issue with a multimeter testing for continuity.

These aren’t sticks that you have worked on, are they?


#8

For #1 and 2, I haven’t even touched the sticks. There are no previous mods on them whatsoever.

For #3, yes, I did. However, I followed the exact same wiring scheme and it seems like only maybe two of them out of about 6 I’ve installed really have this problem. I’ve noted that the ones that have this problem tend to be sticks that are the Soul Edition TE’s. I was told by someone at EVO (one of the modders at least) that I can cut a trace to bypass this problem altogether. Unfortunately, he did not have a TE on him so he couldn’t describe to be exactly where to cut outside of saying a trace beside a blob beside the point where one solders to the home button. It’s kind of hard visually where to look without visually seeing it though.


#9

I’d also like to elaborate about #1 and #2

They both started happening at a local tournament which I attended. For #1, the stick just stopped working suddenly before I even opened the case up. The only previous mod that was on it was a JLF replacement which I did not do. For #2, I actually was playing my friend who has this TE. When he played one match, and then came back to me for casuals, he started having this problem. This was before opening the stick at all and there was no mod at all. What I meant by a resistor was that I heard you can fix this problem by soldering a 10ohm resistor from the VCC to the problem area. I recall seeing something like this on Phreakmods, but I am uncertain.