Mute own microphone in new STEAMWORKS version of SSFAE for PC?


#1

Sorry if this is not the approrptiate place to post a question like this, I dont really post on the board much.

I am looking for a way to disable my own microhone on the pc version, Voice chat options for the PC version used to reside under the Games for Windows Live menu but since that has been taken out, I cant find the option.
I found some voice settings under the settings menu accessed from the steam overlay (shift+tab) but there doesnt seem to be an option to disable it completely. I like to stay on teamspeak with friends playing other games quite often when playing on PC, so id like to find a fix without having to unplug the mic everytime I wanna play SF.

Any ideas? Thanks a lot for any help.


#2

There’s no way to do it without disabling your microphone in everything so far.

You can go into Steam > Settings > Voice and put your mic at minimum.


#3

^Tried that, but it seems to still pickup as normal. Or at the very least, I see the voice indicator flashing as im listening to music and playing. Thanks anyway though


#4

yeah it doesn’t work, i had to disable my mic completely


#5

I just mute everyone I play with, also works. What I really want to know is how to fix those damn audio volume issues.


#6

I wrote this… it works (for me)

http://steamcommunity.com/app/45760/discussions/0/522728813878368574/


#7

That disables your microphone in windows entirely.


#8

A lot of Steam ports have this problem and it drives me nuts. If the developer doesn’t give you mic options, then you’re fucked.


#9

Haven’t yet tried it but betting if I changed it to push to talk in steam’s settings it might work for the purpose. Guess I am gonna find out


#10

Didnt work for me atleast.


#11

Yeah it doesn’t. That is pretty dumb…


#12

lol seems like theres no way around it. Pretty silly oversight by the devs.


#13

I didn’t know most mics apparently don’t have a simple power switch. Glad mine does, I guess.


#14

Yeah, if you don’t have friends you would like to talk to while playing, I guess you could do that.

Though some of us use different VoIPs to communicate with the people we’re in lobby with, so muting the mic is not an option. So instead of you muting yourself, everyone has to mute everyone else, and it’s a really awkward solution.


#15

Ah, the complaint makes more sense now, thanks.


#16

This really blows. Tired of listening to people spamming akuma on their keyboard how do I mute other people and still have the game sound on. I have everything muted. My mic, their mic and receive and send. My mic is also on PTT which is working for me.


#17

Hearing people smash their keyboard or stick is actually not bothering me at all.
Breathe into my ear all you want but what really brings my piss to a boil are these fucking retards that have their mic on and their fucking speakers turned up so loudly that I hear everything twice.
That fucking feedback drives me crazy.


#18

there’s a MUTE option right in the lobby


#19

yeah what really sucks though is it doesn’t remember who you muted, so you have to mute the same player every time you meet them in ranked


#20

The solution given by Noocta is the only good solution as far as I know.
“Steam > Settings > Voice and put your mic at minimum.”

The reason it work like a charm is because every other VoIP softwares use their own volume settings, so it only mute the microphone in Steam games (USF4) and allow you to use it everywhere else.
If this solution does not work for you, this is probably because you have changed your Recording device to something else such as Stereo Mix. Your microphone has to be set to default for it to work.