MvC2 TE 360 problem


#1

So, I have been expecting this stick for about 2 weeks now.
I ordered it through MadcatZ directly, having nothing but problems.
I was put through hell trying to take advantage of a deal they had going.
Regardless, I got the deal and stick.

Well, 30 minutes ago I was happy. Fedex came and I unboxed my TE stick.
Plugged it in and surprise! It doesn’t work.
Wow, madcatZ, wow.

Not only am I furious, I’m surprised.
How can a company put one customer through so much bullshit?

My problem is that the Xbox 360 will not read/recognize the TE stick.
My TE stick guide button just sits there and blinks when it’s plugged into the USB spots on the Xbox 360. (Both usb)

I called tech support and got a lady who talked like it was her first day. I’m so frustrated, I don’t even want the thing, but I want to know what’s wrong with it.

Is there anything I’m doing wrong?


#2

So they’re not going to replace it for you?


#3

They are. I have googled this problem here and at google, and nothing has came up.
I shouldn’t have to be put through all the BS just to receive a DOA TE stick.
That’s the worse part, aside not knowing what is wrong with it, I got crapped on in every department by madcatz.
I called again just to verify that my RMA was coming, and glad I did call again, because the previously mentioned lady didn’t record any of my information. I’ve got it situated now, but this is ridiculous.


#4

At any rate, they’re hooking you up with a deal. Now times that by 100s of people that may have issues, you might be able to see that it’s difficult to trouble shoot everyone’s problem. Just be thankful for a good deal on a TE. Sucks to have the issue, but it’s nice that they’re willing to fix their problem.


#5

The deal was for the WCW3 tournament.
My payment went through with no problems on my end.
I’ve got nothing but problems with them.
I shouldn’t have to RMA the stick 30 minutes after I just got it. Ontop of what I have been through already, this is absurd.
I’m sure I wasn’t the only one to buy a stick during this deal, so this has nothing to do with me asides the fact that I own the stick.
Most people know what their problem is. I don’t.
It just doesn’t work.


#6

Give them a break. Out of thousands of sticks that they sell, who knows how many have issues. Better that you know the issue is being handled now than later. But if they’re willing to fix the problem, that’s a plus in my book.

And really, what kind of issues did they have processing your order? Did you have to bend over backwards to acquire this stick? I don’t get how your order could have been that much trouble. And maybe next time consider ordering through Amazon.


#7

Such is the result of ordering stuff online. There’s always a chance of it being DoA. Are they at least covering the shipping?


#8

@Jamesepoop: My debit card was charged 3 times when it was declined for a dollar each time. I understand if the process for validating my information to my car, but such was not the case. 3 times I was declined because of my bank needing verification for unauthorized charges to my card (I was declined 3 times, so $3 was taken from my account.) They called me and verified that I was making these charges. Well, little to my knowledge at the time, they took $3 from my account when the transaction was declined. So, I only had $111 on the card. Well, this left me with $108.00. The deal ended the next day. Those $1 charges they couldn’t explain because my card WAS declining. They admitted that isn’t supposed to happen, but will be cleared in 3-5 b.days. Well, the deal ended the next day. So, I was fucked.
Luckily the day of the deal I was offered a code that was the same deal. Which was better for what I had gone through.
But still, the previous problem shouldn’t of occured. They fixed it, I thought things were settled.

Nope. This DOA happens. I’m fustrated, but I call them.

I deal with this lady who is completely unorganized. She put me on hold for 20 minutes, 2 times. So, she then gets my information and puts me on hold for 15 minutes only to return and call me “Michael”. Completely the wrong person. She puts me on hold for 10 more minutes and I just want to hang up. But I don’t. She tells me they’ll send me an RMA and Shipping label. I give her my information again for some unknown reason (she probably lost it.) and then puts me on hold for the last time. She asks if I have any questions and I tell her I don’t. I was told I was to get an e-mail and after an hour of waiting, I call back.

This lady is completely opposite of the previous.
She actually got my information the first time, and emailed me my RMA order form while on the phone. I’m still waiting for my shipping label that she told me she’d e-mail me, but I’m glad I called back. I’d be waiting on something that was never coming.

You think people have more problems than this? I highly doubt it. I’d say yeah, I’ve been through a lot of bullshit from madcatz.


#9

you got madcatz’d lulz


#10

Well the first thing, it’s pretty standard practice that they try it multiple times. Honestly not their fault. Sounds like a banking issue, so you really can’t get mad at them. They don’t charge you $1. Your banking institution does. So next time, make sure to save up a couple more bucks.

DOA can happen with anything. If you’ve ordered enough things from the internet, it just happens. They should test these things before product boxing, but it’s possible, they only test the PCB after manufacturing and when the USB cable is in the final installation, they don’t test that because it may not be in their procedure.

Next time order from Amazon. Spend a couple bucks more for their customer service.


#11

Just out of curiosity did you try swapping that quick disconnect end of the usb cable on the stick to another one? I had the EXACT same problem a few years ago with a GameStop 360 controller (that was actually made by madcatz according to the fine print on the back of the box). First I tried plugging it into a PC to see if it would be recognized and it did the exact same thing. So for curiosities sake I switched the quick disconnect that it came with to one off of another 360 wired controller and the madcatz pad worked perfectly.

Its worth a shot.


#12

Jamesepoop, that is where you are wrong.
Madcatz does charge your card $1 a time when verifying your credit card information. That is if your card isn’t declined. Well, they did both, more than once. It’s completely their fault. Look it up. You just seem to be defending and arguing about something you have no idea about. I went through this stuff, I know exactly what happened. The only thing in question is what is wrong with my stick. Not the ordering process. You seem to be focusing and trying to route my problems to the shipping and ordering of said stick, not the PROBLEM with it. I don’t need explanation for something I was clearly told was their fault by the people at fault. I’ll keep the Amazon tip in mind, but nothing else.

@AcidicVision: No, this is my first stick and first time buying from them. I haven’t heard of the method, but I don’t have anything wired. Would it really only be that end piece? I don’t feel like having to wait another 2 weeks just to get my stick back. But if I must, I must. Thanks for the tip.


#13

Well, I tried that other break-a-way trick, and it doesn’t work.
This tells me a couple of things.

  1. My USB ports are working.
  2. I don’t have an at fault Xbox 360
  3. My GH guitar still works.
  4. The arcade stick is the culprit.

I was having doubts about my Xbox 360, but 2 keyboards and a GH guitar prove otherwise.
Thanks for the tip!


#14

Any chance you’re willing to unscrew the top panel and take pictures of the inside of the stick?

Unscrewing the top panel doesn’t void your warranty.

Oh yeah, try it on PC as well.


#15

I’m only pointing out your issues with Madcatz because it doesn’t seem all that bad. You’re making a mountain out of a mole hill. It’s your banking institutions fault for declining the madcatz order. And the fact that you only had $111 to your account, leaves me to believe that you need to save up a few more bucks for your hobby.

Lastly test your stick on PC. If it recognizes on PC, but not your xbox, then you may have a faulty security chip on the stick.


#16

Yeah, it works on GGPO for the PC. I was playing SF3
I don’t mean to come off as hostile or anything, I was just simply stating.
And no, I can’t unscrew it now.