MVC2 X-arcade Glitch


#1

ok i built a arcade cabinet with a modded xbox running mame , MVC2 , SF anniversiary collection (for 3rd strike) , soul calibure 2,KI 1 and 2 , and more but theres a BIG PROBLEM.

Everygame runs perfect without prblems EXCEPT MVC2 : /
heres the glitch:

  1. Player 2 punches DON’T work DURING FIGHTING
  2. The punches DO work in menu and while selecting characters.
  3. The punches are buttons 1 nad 2 on a standeard 6 button layout. iF i make the kicks buttons 1 nad 2 and the pucnh buttons 4 and 5 then the kicks still work to fight but the punches still dont !
  4. the controller is a x-arcade controller with happ buttons+microswitches and happ joysticks.
  5. If I plug in a XBOX S Controller it works fine. Glitch only seems to occur with the X-arcade controller.
  6. im running MVC off the hard drive not the disc(I DO own the disc though i just prefer the HDD for faster load times and not riskin that expensive MVC2 disc :/).
  7. Ive tried this on 3 of my modded XBOXes and the glitch still remains even with fresh copies of MVC2, The Disc, and Fresh game saves.and i dont know y MVC wont accept the buttons as punches on half the controller

Has anyone ever had this glitch or know how to fix it. besides rewireing my whole controller panel with 2 xbox padhacked controllers bc i had it like that before but one of the controllers triggers glitched as if i was holdin the triggers so i ripped out all the wireing and wired it with my old x-arcade pcb board bc the wiring takes up about 10% of the space and the triggers are buttons.

If anyone can help PLEASE DO im mad as hell bc of it and I cant figure it out heres a pic of my mini cabinet too. Thankx :wgrin:

http://badacestuff.com/3d/mini.jpg


#2

its probably that pcb just rewire it with xbox pcbs. The problem with the triggers sounds like you didn’t wire diodes to the triggers.


#3

Go into the button configuration and disable the triggers and white/black buttons; leave it ONLY with LP, HP, LK, and HK on the four face buttons, everything else gets the ‘----’. Verify those work.

Step two; figure out what your other two buttons are. Set ONE to the matching assist button. Test it works. Set the other to the other assist button, test it works. Viola, your done. Leave everything else at ----.


#4

I don’t have any advice, just wanted to say your mini cab is nice looking.


#5

I like the cab too, could have a larger screen though. Looks like a 15 inch. Kinda small.


#6

toodles how the hell did you figure that out? Thank You SOOO MUCH :rock:
You cant set the buttons to nothing but ou can make them taunt so i made the assists , and the unused butttons taunt then the punches worked so i made put the remaining buttons assists. Now everything works fine on player 2 and we cna play without problems !!!

And to yall that like my cabinet thank you :smile:

the screen is a 13" bc i built the cabinet at about 70% scale to save space, have the ability to fit trough ALL my doorways , and more confortablity sitting down.


#7

One of the buttons/triggers was set to LP+HP, and the controller thinks it is always pressed. If its always pressed, no punches for you.

If its set to taunt now, you realize you wont be able to taunt, right? You should really try to figure out why the controller thinks that button that doesn’t exist is always pressed.


#8

no i can still taunt with those buttons lol and the buttons werent being pressed thats the wierd thing!(im 100% sure of that) and thats y i didnt try what you suggested until you mentioned it. but all the while it still worked so im thankfull. i guess we wont figure out y the glitch happend but we know how to fix it thats all that matters