My button's gone insane {PCB help needed desperately!}


#1

The X button on my joystick’s just started shitting itself and acting up, I have no idea what the problem is and if anyone could give me some advice on what to do. everything else is working perfectly, just the one button left and this has really stumped me, and it’s become really frustrating!

I’m using sanwa buttons and the xbox 360 late wired controller as PCB.

I can’t charge focus attacks or anything since x is medium punch. I took it into training mode with inputs on and either…
-i press the button and nothing happens
-i press the button and it needs alot of force(probs my imagination and it just stutters on)
-i press the button and it registers i’ve hit it about 3 times in a second

I then took the controller into windows and tested the inputs, the triggers and analog sticks are shown as neutral, but when i press the x button it either struggles to show an input or machine guns, like flickering…

I’ve tried resoldering all the connections, connecting to the trace and to the TP at the back but none of these make any difference at all. I can’t imagine the sanwa button is faulty, it’s brand new, so any help at all would be great! thanks in advance.


#2

While I’m not an expert I would advise you to take a picture of your pcb and post that and your original post here in the noobie tech support thread (I’ve had good luck, give it a shot)
http://forums.shoryuken.com/showthread.php?t=143234


#3

I doubt it is the button, but have you tried switching the sanwas around and seeing if the other inputs have problems? If so, it may be one of your buttons. It just sounds like a bad soldering job though (not trying to insult you in any way as mine was pathetic). Have you tried getting the wire connected to the X button on the PCB, then getting the common ground cable and touching the wires together. In theory if your soldering is fine the button should activate fine, unless there is a problem with the pad you have soldered to.

Pictures would really help diagnose the problem though. Get some up, try make sure they arent blurry.


#4

photos!

okay, here are some pictures. i’m not sure how useful they are though because i’ve desoldered the wire from the PCB.

here’s the wire and ground soldered to the button, SANWA OBSF-30

here’s the solder point at the front of the PCB, ms xb360 wired late version:

and the TP which was originally fucked up at the back which made me go to the front.

now, when the A button wasn’t working at all from the front (no idea why I just couldn’t get a signal from the trace at the front at all) i went over to the back and soldered there, it works perfect now.

however, this one i don’t think is due to a bad soldering job (although the soldering is very amateur :confused: ) Ive connected the signal and ground from the trace, the solder point and the trace from the TP, and they all give the same stuttering signal…


#5

oh and @ souji: thanks for the advice, i’ll take this over there if this proves less useful

…sorry, lil’ BUMP… i’m kinda desperate for the help here, this is beyond what i can work out and i’d be helpful for ANY advice at all?


#6

If your still having trouble why not scratch the PCB to reveal the trace of the X button (the part going to the signal) to reveal the line of copper. Pre-tin your wires so that there is already solder there as its hard to apply it to such a small line, then just heat it up and get it to stick.


#7

that’s the thing. i’ve tested the traces and they seem to give me the same result as before. this is what’s confusing me as I have no idea how to fix the problem. dyou think wiring just this button up to its own ground would give any sort of improvement? i have no idea why that would work, but i’ve already run out of ideas and i lack any expertise at all here


#8

I dont see why that would work if the rest of your buttons are fine, but I guess it doesnt hurt to try. Are you sure you’ve connected it to the trace. From the pictures I dont see anything scratched on your PCB. I mean actually scratching the PCB to reveal a trace for the X signal and soldering to that.


#9

yeah, sorry, it’s the bit under the red circle :S i’ve definitely scratched the trace open on both sides of the pcb with the same result. i’m pretty sure it connected because there is a signal, just not one that’s… satisfactory.


#10

I dont know how you can fix this then. Im sure if somebody else does they’ll let you know, but it sounds like a defective PCB now to me. Possibly somethings damaged.