My joystick upback/downback won't response! Madcatz TE R2


#1

Hi guys, so yeah I’m new to the forums. I’ve lurked aroud SRK for a while, but now I just hade to sign up, cause my arcade stick is giving me trouble.

I was playing with the stick on my lap, i dont know how, but I managed to drop it, and it slammed into the floor. It wasn’t that hard of a fall, couldn’t be more than 40 cm, and it didnt even get a scratch.

I was like, okey, no worries, then suddenly I was supposed to do a backflip, and my character only jumped straight up in the air. I tried again, but only a jump.

I went to training mode, and enabled the input data, turned the stick 360 degrees, and upbackwards and downbackwards wasn’t listed. Tried to restart, unplugg, and all, but it still wont response to UB and DB. Any suggestions??? Im lost guys, please help :sad:


#2

open up the TE from the top and look at the stick housing. you might of disloged the gate and the micro in there simple fix, just re-adjust.


#3

Thx for the reply, but now my RT and LT buttons doesnt work. Guess I’ll take a look. Will report back in 10 :slight_smile:


#4

haha check ALL the connections and good luck


#5

Okey, this is weird. When I romve the transparent thing, the transparent square gate thats holding the black thing with the red buttons in its place (Lol, hope you understand), i can move all 8 directions. But when i place the transparent thing back on its place the UB/DB wont come out. Don’t understand whyyyy!


#6

the clear piece of plastic you are holding is the gate. with that off you can pick up the microswitch pcb (black thing with red buttons) and reposition back into the housing. make sure its seated inside the housing well. then take the clear plastic gate and place back on top.when you place it back onto the black housing make sure all 4 tabs are secure. look at the 4 plastic tabs on the housing make sure one isnt broken and replace. sound like you jarred the micro’s loose in the housing hopefully nothing is broken but more than likely its just misaligned.


#7

Something in the stick assembly got dislocated.


#8

Thx for the replies, really appreciate it, really But this is the thing. The PCB board is placed back in the housing, and it fits pefectly fine. When the gate isn’t placed on top of it, i can move perfectly all 8 directions. But as soon as the gate is placed on top, and locked with the 4 tabs, UP/DB still wont work. Myabe the gate is broken, or maybe the gates restricts the joystick from fully move around in the hole, if you understand what im saying. The thing is, I can hear to two red buttons getting pressed by the joystick end, but it just wont registerwhen the gate is on top. Sounds really strange… Any ideas?? Thx again though!


#9

Well guys, dont know what i did, but now i got it to work. Messed around with the gate, and it finally got fixed!!