My Ps3 TE Stick isn't functioning , Help Needed plz


#1

Hey guys ,

Id need some help about my TE , I received it yesterday , plugged it to test the buttons , everything replied fine , but then I tried to press the TURBO button and it went to hell , buttons stopped answering and same for the joystick on the ps3.

Now whenever I plug it onto the ps3 , I see a led on the top that links to the L1 button , that blinks non stop but very very weakly and I aint pressing any button , when I press any button , the corresponding led lights up weakly but not how it should be blinking .

When i plug it onto pc it says device isnt working properly

So I think the Turbo module is fucked up , Im thinkin it could be a loose connection … Maybe i could unplug that module as I wont use that feature?

All help is appreciated as Id rather if safe and possible for my skills to fix it myself than to RMA it for a month

Thanks


#2

Did you try reading the instructions? sound like the turbo button is active for R1, find a way to turn it off

-joe


#3

its not like theres a bunch of different buttons to press , I will give the instructions a read and report back


#4

Ok Well nothing more in the manual more than the turbo clear function wich I had already tried and didnt give any results , the led dont even blink as written in the manual after 5 secondes , only the L1 led keeps blinking very weakly , and Turbo + L1 didnt work either.
:wtf:


#5

bump anyone?


#6

make sure your lock switch is off before you turn off the turbo. simple concept, but many people forget about it.


#7

it was off , the problem aint comin from here but thanks for the input


#8

I feel your pain man. As I posted in the other thread

MAN I’M PISSED. So I finally received my TE stick (PS3 version) in the mail tonight and upon hooking it up to my PS3 to test it out I found some MAJOR problems:

  1. Med. Punch, Med. Kick DON’T WORK…LIKE AT ALL
  2. There is a small delay when I press the buttons actually do work
  3. A few times the stick COMPLETELY DROPPED OUT ON ME and nothing worked.

I spent $150 on this freaking thing so I expect super high quality so problems like this are completely not acceptable. I made a small video to show what I’m talking about.

[media=youtube]CsL6p2A7IhQ[/media]

Gonna go back to my trusted HRAP for now until I can get this thing fixed. Oh yeah, when I tried calling the offices were closed, which wasn’t too much of a surprise to me as it’s late but they say you can leave a message and have a rep get back to you but I’m never given the option to leave a message.

Great job MadCatz this will do wonders for your reputation. EPIC FAIL! :mad::mad:


#9

ack that sucks mate , I called and got a RMA number , guess I wont be playing for a month or two now since no one seems to have any clues…


#10

you should try opening up the stick (from the top) and check connections. also, swap connections to another button and see if the microswtich is the problem, the pcb, the wiring, or whatever


#11

can you open the stick from the front without voiding warranty?

what kind of torx is needed ?


#12

Fuck that, don’t open that shyt up and void the warranty!!! Open it up only if the thing is working and u wanna mod it.


#13

The screw is a 1/4 Hex(afaik) to open the front. My TE had the L2 not working completely, button lag and the stick didn’t respond at times or did the exact opposite of it’s input.
Which equated to online becoming completely frustrating. I can handle loosing, it’s just when I push down/back and I jump forward my calm start’s to unravel. So I opened it up to see what the issue was.
The quick disconnects on the L2 were bent 90*'s, while the connects were only half way on and cracked. That was a quick fix, bend them back & slip the connect over the crack’s to being fully connected.
Then upon further inspection I noticed the ribbons that connected to the PCB were only halfway in at a 45* angle. This required an Xacto and patience of cutting away the crap glue job, then resetting the ribbons flush. Then hot gluing the connection.

After that response was lag free, L2 worked and my stick’s only issue now, user error.