My PSP Slim decided to give me the finger


#1

Hi, I need some serious help with my PSP Slim. Today I went to play my Slim but something seriously fucked up happened to it. I turned on my PSP and everything was fine, I could move around the XMB, etc. But when I went to launch the CPS1 emu, it took a shitload of time to load it. Sometimes it can get to the rom selection screen but other times it just gets stuck in the NJ’s info screen. I haven’t been able to run a rom either since it just gets stuck loading the rom too. It becomes even more strange… I also have ToE’s cso in my memory stick, so I decided to run that but the buttons and the d-pad don’t work!! When I go into the Home menu to exit the failed attempt to run the app, I can’t move the highlight to choose “yes” or “no” to exit the application. It will also not let me press X or O so I have to shutdown my PSP the hardway. When I return to the XMB, everything is fine again, this problem happens only when I run apps. :confused:

I have to mention that this never happened before. I didn’t try to upgrade my PSP or downgrade it in anyway. It has been a while since I touched it though… like 3 to 4 months. My PSP Slim has firmware 3.60 M33.

I also have to mentioned that I was applying a screen protector to it today (the invisible shield one with the liquid thing) so maybe this problem could have been caused by some of that liquid getting into d-pad and/or buttons? But I don’t think so since the d-pad and the the buttons work just fine in the XMB. I also opened up my PSP to clean it but I did not see any drops of said liquid.

Can it be a defect with the firmware? I doubt that too since it was working just fine last time I played it. Just to be sure though, I will upgrade its firmware (if it allows me) to scratch this one out. I also noticed that there were some magnets near by where I was working, could those magnets have anything to do with this?

Any ideas as to what happened here? Any help would be greatly appreciated.

  • Dy

#2

the m33 firmware is buggy If I were you I would downgrade it then up grade it again make sure you do it by yourself and not by the quick installers but if is don’t work by yourself try the quick installers…also you should check your memory card out for the speed problem make sure that it is being recognized. I really doubt that the magnets have anything to do with it. One more thing try reinstalling the emulator that could be the problem this same thing happened to me.


#3

Wait, so I should drowngrade my Slim to 1.5? To what firmware should I downgrade to? I also don’t understand what you mean by downgrading it by myself…

Thanks for the help though.

Ninja Edit: So, I installed 3.71 M33-4 unto my PSP Slim, the problem still persists… Also reinstalled NJ’s CPS2 emu… didn’t work either. I don’t see though how that would have helped since this problem is happening to all of the apps I have and in the Home menu.


#4

Go back to an official firmware. That’ll be a 100% if it is or not.

I’m willing to be though, that if you hosed your firmware, it’ll reveal itself in other ways than a nonresponsive d-pad. If you got goop into the internals, there may be a short with the buttons or the dpad itself, so, if that’s the case, I’d flash back to normal and pray that the sony warranty guys don’t see it… Or you could just open and clean it yourself and easily void your warranty.


#5

I bricked a psp using custom firmware sent it to sony and they sent me a brand new psp <3


#6

save money and buy a second battery and get pandora on it.


#7

I had a similar problem to what you’ve having (but mine was the original fat PSP.) I basically just used Pandora to go back to 1.5 and everything was alright, then I upgraded to 3.71 (mine is a fat PSP) for a slim I’d recommend you go to 3.80 CFW if you can.

It sounds like it could be a problem with the internal flash on your PSP. Worst comes to worst…use pandora to go back to 1.5, upgrade it to OFFICIAL firmware…and send it in to be fixed (assuming you still have it under warranty). But that’s my best advice for solving your problem.


#8

Yeah, I just upgraded it to 3.73 official but now I have to find a way to see if my problem still exists since I can’t launch apps under the official firmware.

I went to 3.73 because I might just end up returning it to Wal-mart (despite having bought this PSP in December) and I don’t want the people there to get suspicious.

Edit: As I was writing this I ran an UMD (Darkstalkers Chronicle) and I still have that problem with the Home button :sad: So should I try upgrading to 3.80 or should I just go for 1.5 via Dark-Alex’s 1.5 Proof of Concept? OR should I just leave it as it is and try my luck exchanging it? (I do still have my receipt and I’ve worked in Wal-mart before so I know they can be lenient with this things plus I know the people there).

Oh and thanks for everyone’s input and help.


#9

If an official firmware isn’t fixing the problem then it might be a hardware error and not in the internal flash (from what I know, firmware overwrites everything in the flash0 and flash1) I’d say try your luck, if you have official firmware on there now, I don’t think there’s a way to see that you’ve been using custom firmware since the internal flash isn’t that big (I think it’s only like…3mb or something IDK for sure…)

but like I said, flashing your PSP with a new firmware zaps the old firmware and files on there, besides…I doubt wal-mart will go through THAT much of a process to find out, I doubt even Sony would bother to try and pry that deep into your PSP to figure it out.


#10

Now this problem looks like it is coming from a fried chip in your insides you should scrap it…


#11

Shit, seriously? Haha, what a joke :mad:… anyways, I’ll take your advice and try to get another PSP Slim from Wal-mart… hopefully the CSMs will be cool and they’ll let me exchange it for another one. If worse come to worse (I have to send it to Sony) do I have to downgrade to 1.5 and THEN upgrade to an official firmware so that there’s no evidence that it was tampered with? Or the steps that I took to bring it to FW 3.73 are sufficient enough so that they won’t notice?


#12

All you would have to do it is run a normal firmware…


#13

walmart’s your best bet if you’ve got the receipt. I’d clean off any gunk on the casing though.

and with walmart, you shouldn’t have to worry about firmware. But I’d go to 3.90 just in case.