My Qanba Q4RAF only works on my Xbox?


#1

For some reason it only works on my Xbox when i plug it in. I’ve tried 4 of my friends Xbox’s and it doesnt register in either. I tried all of the usb’s (including the back), turning on/off the xbox with it plugged and unplugged. Whats the exact problem going on here? It works perfectly fine on PS3 as well. Im at a loss on this one. Anyone have the same problems? Let me know asap. Thanks!

-Ray


#2

I have the same problem, and I have no clue as to why it’s doing it. I updated it to current firmware, and still no dice. If you’re still under warranty, I recommend just getting it RMA’d.

It only works on certain computers and xboxs. It’s like a 50% chance it’ll work or fail, but it always works on ps3.


#3

You should take a look at the official thread if you haven’t already: The Official Qanba Fightstick Thread (New products Coming)

There is also a Qanba rep answering questions on that thread.


#4

He hasn’t answered questions in months, and he was hardly helpful when I tried to see if there was something severely wrong with the Qanba PCB, which is known to sometimes fail right outside of the warranty period. I’m calling his reliability into question.


#5

Hes a Spokesman, a sales person not a technician.


#6

Good point. But even then, whenever I’ve tried to communicate with him via email, at some point he’ll just simply stop responding. Very strange.


#7

I’ve definitely had the same experience. Qanba dude replied very quickly when I told him I had a broken door on my Qanba stick. He said he’d help take care of the situation. A few replies later and I never heard from him again. Seems to have good intentions, but (at least in my case) doesn’t seem to follow through.


#8

I say this this way, very early on (right as Qanba was getting involved with the FGC) a Qanba rep contacted me to do a Qanba entry on the What stick to buy guide.
After I asked a few questions, poof I never hear from his agian.

He wanted me to tell everyone that “Qanba was the best” without offering me a logical reason why or even anything for my troubles. At least Razer gave me a stick.
I wanted to know what bloody brand of parts they used, I could not even find out from him I had to look it up on my own.


#9

Are the xboxs on the same firmware. If I am not mistaken the QRAF shi I mean pcbs are not “officially licensed” so a firmware update could be the cause. However it is most likely due to the pcb being a piece of shit.

If I ever got another Q4 for some reason I would switch out the pcb.