My stick is confused


#1

The cord on my T5 stick tore a little so the signals coming from my stick would only reach the PS2 every now and then. I decided I would try to fix this. Since I didn’t have another T5 cord just lying around to replace the torn one, I assumed that I would have to replace not just the torn cord, but also the PCB as well by using another controller. I have a Gamster Reflex Arcade stick so I decided to gut it and use its cord and PCB as a replacement. All was going well. When I wired the Gamester arcade stick PCB to the T5 joystick, all of the directional commands were fine. But the buttons (except for start and select) don’t make any sense at all.

When I connected the Gamerster’s button wires to their respective buttons on the T5 stick, most of them read as if they were different buttons. Some buttons were fine. To show when I mean, the button on the left of the equal sign is the button I wired to and expected the PS2 to read as. The button on the right shows what the PS2 read when I pressed the button:

L1=R1
L2=L2
Square=L1
Triangle=Square
Circle=Circle
X=X
R1=R1
R2=R2

If you notice, no matter what configuration I do, Triangle is read as neither a correct nor incorrect input. Its just missing… To makes things even more confusing, I went into training mode of Guilty Gear and put the settings on “input” which gives a visual representation of what the PS2 was reading. After pressing my jacked up buttons I see that the PS2 is actually reading multiple buttons when I only hit one. The buttons above that I just posted just seem to get priority. I don’t get it? I don’t know how to fix this. Does anyone even know what I’m talking about?

I know I connected the wires right. Their appropriate button assignments are printed right on the freakin’ PCB. And by the way the buttons are the original T5 buttons. PLEASE HELP!!!


#2

Sounds like one of the ground wires is touching something else or the solder blobbed together somewhere. Double check the triangle connection. It probably has the sliiiiiiiiiiiiightest bit of solder touching between the signal contact and ground contact.


#3

Why in hell would you use a Reflex pcb???

Did you use a common ground linking all of the wires? If so, that’s the problem. Run two wires for each button directly to that button and nothing else.


#4

Incorrect assumption. I replaced the torn cord on my SC2 Hori with a regular PS2 cord. Simply spliced the two cords together. Works great. Much easier than hacking an entirely new PCB. :shy:


#5

Because I actually had one. To make myself look even worst, I actually used the wires in the Gamerster and connected those to the buttons. So I actually never attached anything to PCB. But yeah I did do the whole 2 wires to each button thing.

I figured that out the other day. :sweat: I do everything the hard way… ug. -_- Okay so I’m going to start over. I’m gonna go get a PS2 pad and use the PCB in that. When I go buy wires to do the wiring, what kind should I use?


#6

If you’re planning on doing the solder less hack, then remember one thing. DO NOT buy stranded wire, because I made the same mistake. Look for 22 gauge solid wire (Radioshack).


#7

I don’t understand why everything has to be this hard. I almost had everything fixed but then the buttons screwed up as I mentioned before. Right now I’m lost and confused and don’t know what to do next. My main concern right now is replacing the cords. I have a gamerster arcade stick cord and a PS2 pad cord(sort of. Out of the 8 wires that are normally in the cord, only 7 of them are soldered on to the PCB. The eighth one is cut short and is not attached. This is a brand new PS2 pad that I haven’t even used yet). How can I replace them properly?? I thought I knew how but now I’m only screwing even more. Could you explain how to splice the cords together?


#8

Hi, I have a similar problem but with Xbox version. I’ve made the tests connected to a PC using Super Joy Box 11 Xbox to USB adapter.

I have replaced the crappy buttons by Sanwa 24mm ones and when initially connecting them back, they worked but the screw was longer and I had to buy some packing rings to put the button higher; then they produce double connections. For instance, triggers: when I push RT, a line of LT goes up. I’ve solved some problem testing trial-error (I’m an absolute Noob) with 4k resistors soldered on the ground connection (as I remembered Xbox 360 padhacking issue with triggers), but still two buttons make double connections.

Could anyone help? I’ve posted something similar in the “Official” Xbox Gamester Reflex thread and no answers, only complaints of some users.

Thank you very much in advance.


#9

Nobody answered, but thanks to a fellow technician I found the problem of double button input is solved:

The original buttons had rubber pads inside (not microswitches) unlike Sanwa, so, he put 22k resistors and it worked fine.

The solution to the problem I had is here. You can try it by yourselves.