My Tatsunoko Capcom Arcade stick broke! Any ideas?


#1

Hello,

I’m glad I was finally able to register I’ve been a long time lurker of these forums and I just want to say you guys make some really great looking stuff.

Now with that out the way here’s my problemo… I have a TvC arcade stick that I modded with Sanwa buttons and a JLF stick. The other day my Stick fell from my top shelf and hit the ground hard. I plugged it in to make sure it worked and it did just fine. Then I started playing and the stick went dead like it had no power. Nothing was responding at all. So I did the usual battery tricks and no luck. I turned off my wii and went to try TVC out again and the stick worked for like a few seconds then died again.

I thought maybe it was a loose wire so I opened it back up and checked all the connections and everything was tight. I’m not an arcade stick pro so I can’t really tell what might be wrong or why it’s not getting power or holding power or whatever. I’m just really disappointed because the stick was nice.


#2

Could you take pictures of the PCB? Maybe something is shorting or coming loose.


#3

yeah sure I’ll take some now.

well might be a sec I have to take these tiny screws out.


#4

I got the pictures taken. I had to wait till I had better light. It didn’t come out so good before.

http://img703.imageshack.us/i/0000011.jpg/
http://img508.imageshack.us/i/0000010r.jpg/
http://img255.imageshack.us/i/0000009a.jpg/
http://img402.imageshack.us/i/0000008zf.jpg/
http://img836.imageshack.us/i/0000007f.jpg/
http://img99.imageshack.us/i/0000006bi.jpg/
/img35.imageshack.us/i/0000005w.jpg/
http://img690.imageshack.us/i/0000004c.jpg/
http://img406.imageshack.us/i/0000002e.jpg/


#5

when you say you checked all the wire connections did you check just the connections to the part or did you also check the connections to the board? also have you checked the connection between the board and wiimote plug?


#6

Yeah, I pretty much disconnected the Wii mote and checked there first and tested with the CCPRO to make sure it was still sending signals. Then After it appeared the wiimote was still working I Played around the batteries and put in brand new ones and even re-synced the wiimote and restarted. The Stick lit up like it was getting power and it worked for a few minutes then died again.

That’s when I cracked it open and got my led light out and started tracing all the connections and checking the wires. I checked anything that had a plug. The chord that goes straight into the Wiimote is actually soldered right into the board so it doesn’t have a plug. This really made me annoyed because I’m thinking either it might be shorting out somewhere or the board is screwed. When it came off the shelf it hit the floor hard. So hard that it knocked the octagon plate right off the switches. I was thinking about going to best buy and doing the old switcharoo but they don’t have anymore LOL!

I even thought it was the switches possible since they apparently got knocked out of whack from the fall so I plugged up the JLF stick I had laying around (I forgot I went back to the stock one) but it still acted up the same. Really sucks this was a great stick and I liked it a lot. I’d like to pretend I know what I’m doing when I look at a circuit board but I don’t. I bet it’s something simple too.


#7

i mean it definitely sounds like it’s shorting out somewhere. if it’s booting up and working temporarily then cutting out then that’s what i would assume.You could check the solder point connections on the board and make sure one of em didn’t get knocked loose and is touching somewhere else. I’m sure you checked the board itself and if theres no obvious cracks/bends/breaks in anything i dunno :frowning: try to see if theres solder touching anywhere it shouldn’t be?


#8

It looks like your L3 inductor is broken off. I’m no engineer, but there’s certainly something missing. What it may do, or if it’s causing the problem, I can’t be sure. What I could suggest is hunting down a new TvC PCB in Trading outlet. They shouldn’t be much more than $15 (As Toodles’ PiiWee is about that price, and basically does the same job). I’ve seen them on sale before. Or maybe an electrical engineer will chime in on this.


#9

Thanks a lot for all youse guys help.