Need help! Fightstick unresponsive after trying to update brook converter firmware


#1

Happy Saturday morning to everyone.

Little background. I have a XBOX360 madcatz TE S chunli fightstick. I modded it with the phreakmods cerebus PCB to work on the PS3 and PC. Just got SFV so needed my stick to work on the PS4. Bought a brook converter and connected it all up and everything worked great (except for the 8 sec delay). So i attempted to update the firmware on the converter. Plugged everything in to my PC, downloaded the update and began the process. So i looked away for a bit and came back and saw the stick had no connection light, the converter still showed its link light but i failed to see if the update went through. At that point i unplugged the stick then tried to plug it back in. Now the stick does not turn on. The converter still shows a light but nothing for the stick. It still does not work when plugged in to the PC w/out the converter. I opened it up to make sure all the connections are good and everything seems ok. Has anyone had this happen? Any help would be much appreciated!


#2

This should be posted in the brook converter thread, not here.
The brook people read that thread, not new ones like this.
And what converter did you buy anyway?
And what firmware version did you download? The newest one as of yesterday or two days ago? And for what adapter? What model firmware? Did you download the INCORRECT firmware? What was said on the software when you ran it? You said you looked away so I guess you didn’t pay attention (you’re not supposed to look away when flashing stuff, you miss error messages. That’s irresponsible behavior).
Did you run the software again? In your message you didn’t even say what software you ran.

Please don’t just reply to the last sentence. Answer everything I wrote. (I can’t begin to tell you how many people respond to the first and last msg, answer that and ignore everything else).


#3

Should I just take this post and repost it in the brook converter thread?

I bought the 360/PS4 converter

the firmware was Xbox360/xbox one to PS4_TE_21_201607. So obviously i downloaded the wrong firmware. I needed to download the xbox360 to PS4 version.

I definitely realize i messed up there but was trying to do a few things at once. Not smart.

I ran the software that came with the firmware. Just tried to run it again. As soon as i plug in the converter with the fightstick it goes directly to saying ready for update. When i try to do the update it does it says update failed. According to directions i’m supposed to get the stick to go into update mode by doing a button combination but it doesnt give me that option. If i run the update without the stick connected the update says successful. Then i plug the stick in and it has the green light around the xbox button but it wont let me get out of update mode.

Thanks again for responding. I realize this was probably all just negligence but i’m desperate here!


#4

Ok so you admitted you flashed the wrong firmware. That’s important and thank you.

The Brook people have recovered adapters that were flashed with incorrect firmware.
Please send a private message to @Brook_Engineer and @“GOGO.Zippy” and also post in the thread and explain exactly what you did wrong.
I believe they have a custom file you can download which will reflash your device. You MUST tell them carefully what adapter you have and the WRONG firmware you flashed.