Odd Controller Bug [fixed]


#1

So, recently I tried to play Injustice with a friend, and we encountered the most unusual bug. If a stick is first player, the controller will function in the menus, but when editing the controls in character select nothing happens to any button press (The controls will not change), and when in a match (Versus, ranked match, or player match) the stick will not function at all. With numerous testing, we found out that 1P stick will not function, but 2P stick will. It isn’t a problem with the stick itself; as when we change which stick is 1P, the bug reemerges. So for the example, let’s call them sticks ‘A’ and ‘B’. Starting the game with A without B plugged in (As in, restarting the console), once I go into character select and attempt to edit the button layout, pressing any button will not change which button the command is assigned to, but it will act like a button was pressed and move down the list (And then once the match starts, nothing will work at all). When B is plugged in, everything works as normal. So restart the game with only B plugged in, we go into character select, and now B can’t edit the button configuration, and when A is plugged in everything works as normal (in second player). So regardless of what stick is 1P, it refuses to function, but 2P works fine. We tried having a controller as 1P, then plugging in A (2P) and B (3P), and now A woks fine, but B no longer works.

So, anyone have any clue as to why this might happen? It just emerged today; and my friend attests he was playing just fine before he left for work.

Edit : For anyone who encounters this bug, the solution is to delete your player save.