Odd issue with my SE stick


#1

Been searching for a while on an answer to this before I posted a new thread. For some reason, one of my SE sticks disconnected itself from my 360 every time I press up on the joystick. Everything else on the stick works just fine. I’ve tried to trouble shoot it myself since I’ve already voided the warranty.

So far I’ve already tried a working JLF, two stock madcatz sticks, and a LS-32-01 and all four sticks give the same issue. I’ve tried two wire harnesses for the joystick, and I have tested the original harness in a separate stick. The original harness works in a different stick, and putting a new harness in the defective stick yields the same issue. However, when I just touched the pins for UP and Ground together on the PCB with a paperclip, the pcb seemed to work flawlessly. I’ve disconnected every wire harness from the pcb (turbo, headphone, buttons) only leaving the joystick attached and it still disconnected the controller from the xbox when i press Up on the joystick.

Any help or suggestions would be greatly appreciated. If anything I will just sell or toss the pcb away and put a DB-25 in the case.


#2

Sounds like you fucked the PCB By not removing the washer on the default stick.


#3

Is that something that’s repairable?


#4

the PCB? Of course pretty sure its just the pcb the microswitches sit on.

Sanwa JLF-TP-8T Ball Handle Joystick, 4 & 8-Way Adjustable

Buy one of these and pop it in, I don’t know his real issue without pictures of the insides etc http://www.lizardlick.com/pages/joysticks.shtml


#5

He already tried a JLF?


#6

Previous Statement? “Buy one of these and pop it in, I don’t know his real issue without pictures of the insides etc”


#7

need more details

i had a problem like this when i used an adapter. i plugged a blaze ps2 to 360 adapter for hori arcana in the 360 and a hori se in the 360 while it was off, when i turn it on everything was fine. automatically the se was first player and the arcana was second . i hit up on the arcana and it disconnected. this might not be your problem but you need much more detail so we may more accurately determine your problem


#8

It isn’t the pcb on the joystick that is acting up, so it isn’t the washer issue. The PCB that is giving me the issue is the actual pcb that controls everything. Once I get home I can take a few pictures. Already tried four different joysticks that work flawlessly in other cases.