Ongoing joystick problem!


#1

I recently decided to build my own arcade stick and have encountered an ongoing problem. I did a lot of research on how to build the box and how to wire up the pcb and finally started my project. I bought all the tools necessary to build the box. Afterwards, I decided that I would go with all american arcade parts and purchased an iL eurostick, 9 iL competition convex buttons, and a solderless common ground madcatz pcb from modchipman.com. I received the parts a few days later and started my build. The pcb looked really straight forward as all I needed to do was put the wire in one end of the screw in terminal and the other on a quick disconnect. This is where the problem occured. I had a wire going from the terminal to the buttons on every button through the microswitch. I also had one daisy chain from the ground on the terminal to every single microswitch as i had seen done on many forums. I plugged it in to my computer to test out the buttons and when i opened up the controller under control panel, I seen that it was showing that my joystick was stuck in a certain direction. All the buttons were working fine but the joystick was not only stuck in one direction but was reading wrong directions no matter how i moved the joystick. I then decided that the pcb was messed up and purchased another identical controller from gamestop and a soldering iron. I used slagcoin to solder all of the wires hoping that my problem would be resolved but once again was getting the same problem with the joystick showing weird directions. Does anyone know what I may be doing wrong or whats happening. Please help me out, Thanks.:sad:


#2

http://www.cherrycorp.com/english/switches/miniature/images/e21_cutaway_2x.gif

Your quick disconnects should be attached to NO terminal and Common terminal. Doesn’t matter which one is attached to which, as long as neither of them are attached to NC terminal.

As for the stick registering wrong directions… you probably have the QDs hooked up mirrored. When the stick is pushed down/left, the actuator is pushing the up/right microswitches, not the down/left ones.

Just check the controller through control panel and rearrange the signal wires until it’s right. Or use logic to figure it out, whatever works.

If none of that works, well then… take a picture. Can’t really figure out much else using just the description you’ve given.


#3

I have all the quick disconnects connected correctly. I have the buttons connected through the no and the ground wires connected to the common. The weird thing about the joystick is that when I push down, it comes out as bottom right. When i push up, it comes out as top right. When I leave it neutral, it is stuck on right. When I push left, nothing happens.


#4

Your right is what’s broken. It’s just staying constantly triggered.

It’s either the switch that’s broken, or you’ve got the right signal touching a ground somewhere (either on the pcb, or somewhere along the way to the switch).


#5

I want to post some pictures to possible determine whats wrong but I don’t know how. I have checked the forums and it says there should be a manage attachments button but i don’t see it. It also says there should be a pictures and albums link in the user control panel but I also don’t see that. If someone could please let me know how to post pictures I would really appreciate because I want to know whats wrong with my joystick. Thanks


#6

Posting Attachments is for Premium Members.
So you not able to do that.

To post a picture, have the image you want uploaded somewhere online.
Then click on

http://forums.shoryuken.com/aria09/editor/insertimage.gif

and paste in the link when you type Post.
BAM! You have picture show in Post.


#7

upload your picture to somewhere like imageshack then in this forum just above the box where you type your message there’s a small square picture of what looks like 2 pyramids and a sun…click it and paste in the url of your image

Edit : Doh…beaten to it lol :slight_smile:


#8

Thanks for the info, guess i’ll sign up for premium.


#9

Whoa, you just turned Premium.
But the second part of my Post, you not need to be for posting Image.

Just do what I typed, and Shinobi Sanwa.
Sorry for confusion, and your $3. :sad:


#10

Ok, first of all sorry for the bad lighting on the pics. so I’ve made sure that no wires are touching each other, I removed and re soldered all of the wires, and replaced the microswitches with working ones and still have no luck. These pics are to show how my pcb is wired and what the computer is showing when its plugged in without anything being moved. I will try to get a close up pic of the dpad. The diagram is from
www.slagcoin.com and this is exactly how i wired my pcb as this is the same controller i have.

http://forums.shoryuken.com/picture.php?albumid=443&pictureid=3285

http://forums.shoryuken.com/picture.php?albumid=443&pictureid=3284

http://forums.shoryuken.com/picture.php?albumid=443&pictureid=3286

p.s. - don’t worry about it jdm, premium is much more convenient


#11

Need closeup pics of your padhack.


#12

ok here’s the the close-up pic of the pcb. The white wires are the signal and the black wire is the ground that I’m daisy chaining. Sorry for the bad lighting.
http://forums.shoryuken.com/attachment.php?attachmentid=49885&stc=1&d=1253190737


#13

This may sound stupid but you tried to go into the settings and calibrate the stick right?


#14

No, I just went to game controllers in the control panel and tested it out. Was I supposed to change the settings or something?


#15

Should I have calibrated it? If so where do I do that?

EDIT: I tried the calibration but still no luck. For some reason it actually worked once when I was trying it and then the problem came back. Is there something I’m doing wrong? I’m starting to think about returning this for a cthulhu board.


#16

Calibration is only needed for analog sticks.

Do you have a multimeter or continuity tester?


#17

No i dont. I’m guessing I could purchase one at radio shack. What would the multimeter or continuity tester determine? Also is there any problems you can see from the pictures shown? Thanks


#18

My guess is somewhere your right signal is being grounded (or the switch is broken).

A multimeter or continuity tester will tell you if that’s the case.

You can get one at radioshack cheap.

Only thing I can see for you to try right now from the picture is to make sure absolutely no solder on the right signal on your pcb is crossing from the signal to the ground. If those are being bridged it would cause the problem you’re having.


#19

Ok thanks for the advice,that may be the problem i’m having. How can i completely remove all of the solder on the pcb that way i can resolder everything?


#20

The only solder you will need to check is what’s activating right on the dpad, that’s the ony thing giving you issues.

But you should really get one of the mentioned tools to help you diagnose the problem.