Overclocking USB ports for Windows 7, is it possible?


#1

So I’m playing a game yet I’m having input issues in regards of my usb ports.
I notice the sample rates are not up to par and I need to overclock my USB ports.
Problem is, I’m on a Windows 7 and everything I do fails horribly.

I was told to check out this website:
http://www.ngohq.com/news/15043-how-to-increase-usb-sample-rate-in-windows-vista-7-a.html

So I do the instructions step by step, but could not help but feel that there are some steps missing.
Once finished, nothing happened, still in the same situation.
I thought “maybe I miss something, let me do it again”. I did it again, and now my USB driver does not recognize my joystick, WTF?!?!?

So now I’m even wondering if it’s possible to overclock your USB for Windows 7.
And if so, please tell me how :frowning:


#2

I’ve never heard of overclocking USB ports and I don’t really think that’s necessarily the right term to use? I’ve been into overclocking for… well a long time. All in all, I think this is in your head buddy. I can’t see how it’s going to make that much difference. What exactly do you mean by input issues and how do you know it’s definitely the usb ports? I’ll have a read up tomorrow and see if I can find anything though, too late now! I’m always happy to learn something.


#3

People do overclock their usb ports actually, I believe they run at 125 hz stock, but you can bump them up to 1000hz.

Sorry though, I don’t really have any insight on how to get it done in windows 7.

edit- http://www.overclock.net/computer-peripherals/596276-changing-usb-polling-rate-1000hz-lower.html


#4

Back in my FPS days we had to overclock our mouse ports if they were connected USB due to lag (it would lag a good 30ms if not overclocked).
No doubt you can feel the differences.

Now I’m playing fighting games on CPU, I heard a lot of people who play fighters on there CPU overclock there USB ports to run there games flawlessly.
Sadly, when doing the method posted about, nothing happens and I’m still suffering through random lag on my fighting games.
The thing is, I’m not running into “input lag” per say, it more a long the lines of “I hit forward twice, yet the buffer on my USB reads it to were my 2nd forward is still being registered, so when I do an attack it’s a forward attack rather than a dash up natural attack”. When I tell people about this (or when they play the game on my CPU), I’m told it’s not lag at all, but a USB issue.

Ugh, I just don’t know how to get them overclocked on Windows 7 :frowning:

Nice link!
Let me look into this… I hope it works!


#5

Forget about “overclocking” your usb ports, get yourself a dedicated USB PCI card.


#6

I was working through this a couple days ago and couldn’t get it to work - ports always stuck at 125hz

That doesn’t affect the default polling rate of 125hz.


#7

If it is a directx game you are playing and you have a nvidia graphics card, create a profile for the game. Set maximum prerendered frames to zero.

Any “input lag” you are experiencing on a fighting game has nothing to do with USB polling rates. Fighting games do not function like games which use a mouse where controller precision is analogue. 125 Hz means the hardware is polled every 8ms. Your game would need to update at 125 times per second before you would even be able to begin to notice any polling resolution issues if you were not a human. [media=youtube]wNomspJDLtk#t=2m30s[/media] polling rates?


#8

DAMN!!! lol

But um, my prerender frames is already set to Zero.
Not to mention, it’s not input lag I feel.

Sadly, brighenne link did not work for Windows 7 :frowning:


#9

I followed the instructions and was able to get my joystick at 500Hz and my mouse to 500Hz. I’m on Windows 7.


#10

Oh wow strange, wonder why I can’t get it working.
I even went ahead and under clocked it down to like 16hz and felt no differences at all.

What kind of stick are you using?
Also, did you follow hte instructions “exactly”? If anything, why not tell me the steps you took, if you could?

If I don’t find a solution soon, I think I’m gonna have to go ahead and just call it quits and down grade back to windows XP.


#11

125hz is already more than enough for any fighting game out there. Spotty inputs are indicative of a problem with the device itself, the device driver, or the game you’re playing. Try a different controller if you can.


#12

since we all know this is for some BB esque game XD

Honestly it seems your issue isn’t as much with the USB port as much as your device that is connecting.
http://www.xpadder.com/
Hook up your device and use this software to run it. If it is a certain game that i imagine your playing this makes a big big big big difference.
LOTS of device lag on PC if they are not designed for PC, also if your using a converter that works well for PS2>PS3 conversoin does not mean it will lag the same on a Computer. Exact reasons i’m not sure on but i have 1 or 2 converters in my closet that show this horribly well.


#13

hi one Qs, i have a TE Fightstick and when i connect to PC with Windows XP all is fine but when i connect to pc with windows 7 only register drivers but doesnt do nothing, what can i do? sorry for bad english.


#14

I have a dual install of winxp 32 and win7 64. When I play with my ps3 pad or my ps3 madcatz SE I notice a small input delay on the pc version of SFIV when playing on my win7 install. Yet when I switch back to xp and play, everything is fine. I wonder if this overclocking usb stuff will work… hmmm


#15

i have done this on win7 and it works fine despite being stupidly unintuitive to do compared to on xp


#16

Ugh, wish I could download Xpadder, but I can’t avoid the charge without downloading it.
Sorry, couldn’t get anything out of that :frowning:

This is starting to sound like more and more like an OS issue.
This sucks, I really like Windows 7, but to enjoy lagless input games, it seems like my only option at this point is to down grade seeing as how nothing seems to be working :frowning:


#17

Well I’m so glad I have a duel install , was never gonna risk going 64bit without a back up 32bit install.

Still I’m gonna give it my all to see if I can fix this before I fully blame win7 64. Currently updating drivers and so forth.

And that setting pre-rendered frames to 0 thing, thats something I’ve done on my xp install but I can’t seem to get access to nvidea control panel on my win7 install, which I’m trying to fix now. We’ll see…


#18

You are using a 360 stick right? On some type of anime style game yes?
I am running the same game on Windows 7 x64 flawlessly, BUT I know the directional input lag you speak of. Only on the directionals, you will experience some "sticking."
How I fixed this: Use Joy2Key for directionals ONLY.

  1. When you “config” the buttons map 8 6 2 4 for the directions (MAKE SURE JOY2KEY IS NOT RUNNING YET!) then press buttons as normal for the rest.
  2. Start Joy2Key and make sure you turn the POV option on in the “Others” section. Map your 8 6 2 4 to the appropriate directions/POV hats.
  3. Start game. Enjoy proper dashing instead of walking into attacks once more!

Alternately, a PS2 stick with a Pelican adapter seems to work perfectly with no additional help needed.


#19

See, I was told NOt to use Joy2Key but in my mind I thought it was a good idea.
Well, I’ll give your idea a shot and see what happens! :smiley:
But… um… can you link me a place were I can download joy2key for win 7?

FYI, I actually am using a Pelican Adapter ;(


#20

http://www.electracode.com/4/joy2key/JoyToKey%20English%20Version.htm
Works fine for me. Try compatibility mode if you want but works fine for me on Win7 x64