Pad hacking question


#1

I’m trying to hack a madcatz ps2 propad but I am running into problems with start button. When I wire it is always seems shorted even though it isn’t. has anybody else encountered this problem?

Thanks.


#2

I’ve encountered problems with PS2 pads in general…I like the PS1’s. Does it just hit start and nothing else? Or does your controller just have a kanipshit?


#3

It acts like start is turboed. I tried everything but I can figure it out.


#4

How are you wiring the start button? Are you using a different ground than the other buttons?


#5

Anyone know if you can hack the MadCatz “NBA” PS2 pads they have at EB/Gamestop for 4.99 or the “official” Gamestop PS2 controllers? I tried doing the NBA pad, but it just acts like all the buttons are being pressed rapidly.


#6

No, same ground. Odd thing is it’s like there are two start buttons and two select buttons side by side.


#7

I think that’s your problem then. If I’m reading this correctly, the PS2 pads use two sets of grounds; one for the Start, Select, and Analog; one for the rest of the buttons. The normal gameplay buttons are analog, start, select, and analog are digital.

http://mywebpages.comcast.net/jdpyle1/controls_playstation.htm

That might well be your problem too Digitalbooty.


#8

Sounds more like there was a ‘turbo’ or ‘slow’ button on the gamepad. Test the other points in that area.


#9

I haven’t wired start, select or analog to anything. I just have a common groung for the directions and a seperate one for gameplay buttons. I even tried using the same ground for everything (excepty the start, select and analog) and still the same thing. It doesn’t make sense to me. Everything is wired fine. I just wired a gutted doa4 stick to a madcatz nba dual shock. It just hits commands rapidly. It’s very strange.


#10

ShinAkuma: I’m also working on one of these with the same result. Let me know if you figure it out. I’ll do the same.


#11

Wow, you should make a thread on that. Or post in the padhacking thread. But not hijack someone elses thread.


#12

Well, I didn’t want to make a new thread when this one was asking for similar help. I posted something in the pad hacking thread but no one responded. I just thought it was pointless to make a new thread. You really think I should make my own? This thread should probablly be in the pad hacking thread, too.


#13

Thanks. Unfortunately that doesn’t remedy the issue. :frowning:


#14

Have you tested to see if you wired the turbo button for start? If there are two sets, perhaps the one set is “turbo” and the other is regular. If you wired up the turbo one, it would definitely do this.


#15

This pad model does not support the turbo or rapid fire functions.

http://www.cduniverse.com/search/xx/games/pid/7242185/a/PS2+Control+Pad+Pro.htm


#16

I’m out of suggestions then, sorry pal.


#17

That is why this is so frustrating, the problem makes no sense. Thanks anyways.


#18

Again, I’m using a madcatz as well, and mine works fine now–using two grounds. What I don’t understand is that I feel confident I had already tried using separate grounds and it was a no go. Good luck Shin


#19

How did you wire the start button?


#20

Just to the left of the recess meant to house the right analog stick, there are two solder blobs–one for start and one for the start/select ground. I soldered to those.

On my PCB, there’s no convenient solder point for either start or select. I tried soldering to the start line in four separate places; none seemed to work but the solder blob.

That’s quite a string of words; if it’s not clear, a friend of mine has a digital camera, and I can probably get a picture posted in a few days. whew. Hope that helps.