Padhack for xbox 360 issue


#1

recently i saw Upas’s guide ( How to padhack an 08/09 Madcatz 4716 Common Ground Xbox 360 Pad ) and tried my hand at hacking the madcatz “4716” xbox 360 controller.

i tested the controller before i gutted it and it worked fine, but as soon as i finished wiring everything up i’ve been getting a strange issue. basically what happens is that when i plug the controller PCB into my computer the guide button lights flash only once, then nothing. my computer doesn’t even recognize that it’s plugged in anymore.

i have no idea what’s going wrong, but i have a strange feeling that this is being caused from a short somewhere on the board (although i can’t see any visible issues with the solder on the contacts anywhere, it just seems that the power isn’t going to the controller right). i would greatly appreciate anyone’s advice on this problem.


#2

Do you still have the original USB attached? Did you Invert the triggers? Try a different USB port, too. Sometimes they only provide 3.3V, and it needs 5V.


#3

yeah, i took a break to relax and then went back to look at it. i inverted the triggers, but sometime during the wiring process the original USB cable wires became loose from the contacts (the green and white one). i’m going to try and solder them back and test it out, hopefully that fixes the issue

*edit: i really want to make sure everything is working on it before i wire it to my other PCB. call me over compulsive, but i don’t want to ruin 2 PCBs. by plugging it in after i check damn near ever point with a multimeter the only point that gives me some sort of an issue is the guide button, but that isn’t as big of an issue as it not fully starting up


#4

Which revision of the 4716 is this. Some later versions don’t need to have their triggers reversed.


#5

so it’s working for now. turns out that i had a really bad USB cable connection, i mean i’m surprised the thing worked out of the box is how bad it was (and yeah i only have myself to blame for not seeing that glaring issues).

what i ended up doing was just removing all of the USB wires from their connections on the PCB. this was kind of a pain because most of the original USB wires had ripped off leaving a frayed mess that had to be cleaned up with some soldering wick and a tooth brush. after that i cut some extra wire bits and spliced them to the original USB wires, then used electrical tape to prevent any of the newly spliced wires from accidentally touching. then i heated up the cleaned off connections, pushed the new wires through, and then soldered them which did the trick.

*for dev: the controller is from 2011, but inside the PCB is exactly like the one Upas used: Main PCB is version 4716-1 ver. E and a the D-pad addition is 4716-2 ver. C. the hex inverter is up and running without causing any issues so far. i think the only problem i had was distinguishing which wire was supposed to be which trigger, but after testing them i was able to figure out which one did what.

now after doing some research i did find out that the 07’ madcatz PCBs don’t need to be inverted (i think they just need a resistor from high to low or something along those lines), but when i started to look into the models that came after that year, things get kind of funky. i don’t know if it’s just me but it seems that now madcatz are using about 3 different PCBs for their current 4716 model pads.

1 seems to be the older 08/09 PCB just thrown into a case with a “2011” date printed on it (the one i got) and then there seems to be 2 other pads with PCBs that don’t need to be inverted, but are still thrown into the same case with the “2011” date print. i only say this because i recall maybe 2 other people around the forum having almost similar issues with their triggers and inverters, but i think they had different PCBs in their pads (this is just a wild guess that’s being based off of the dates of the original poster and a few minor details that didn’t seem to be the same from one another), but the kicker is that by removing the inverter their problems were solved (which does confirming that they’re newer pads that don’t need to be inverted).

now this is all just my speculation and i can be completely wrong, because without looking at the model numbers of both the Main and D-pad PCBs of the users’ pads i will never have evidence to back up my theory. but honestly i don’t think it’s that far off for a company to just use older overstocked components that still work perfectly with newer ones until they use up all the older ones.


#6

They still use the same PCBs as the one Upas guide wrote, they just update the model year.

Pre-08 versions needed a Resistor from Wiper to Low.

Glad you figured it all out. I don’t like the mess that Madcatz USB connections leave behind, either.