Paewang Revolution PCB Home button stuck


#1

Hello guys. I own 3 Paewang Revolution PCB’s and two of them have a problem. On one of them my home button is stuck. Joystick recognizes it as it’s always pressed. On other one buttons 3, 5 and 7 are always recognized as pressed and I tried everything to fix it without any solution. I know there are users that already had this problem. I tried searching through the forum but had no luck finding solution, only problems. Is there anything I missed? Is there any solution to this?


#2

Pics of your PCB and wiring plz


#3

I totally desoldered it. I used multimeter to test if the home button contacts are connected and they are not. Apart from that, I don’t see anything that could cause this. It was working just fine until it just started making this problem during the play on Xbox.

I’ll take a picture and post it when I get home, but, as I told you. It’s totaly desodlered and there is no any unwanted contact causing this buttons to be pressed.


#4

In my experience this is a common problem with these pcb’s which is why I stopped using them in mods. As far as I know there is no fix, at least with the original PS360 board you could force a reset which had a chance of fixing it.

Sorry.


#5

How is that reset performed? Maybe I should try here.


#6

You can’t on one of these pcb’s, it seems to be a unique feature to the original PS360 board.


#7

I knew this sounded familiar. Phreak wrote up using pull-up resistors to un-stick stuck buttons on a 360 TE PCB. Perhaps you could give that a try? http://www.phreakmods.com/madcatz-360-te-pcb-fixes


#8

Will do when I get home. Thanks for your help.


#9

It acutaly worked. I can’t beleive it. I just used 2k resistor since 4.7k was to strong. You have to measure the voltage and see what resistor you should put.
All you should do is use the tutorial this guy made.
Everything works fine now.

Thanks again!